summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 26f75b8..2d2eedf 100644
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,8 @@ INCLUDE_FLAGS := $(shell pkg-config --cflags libsystemd)
VERSION := $(shell $(PYTHON) setup.py --version)
TESTFLAGS = -v
+CFLAGS = -std=c99
+
define buildscript
import sys,sysconfig
print("build/lib.{}-{}.{}".format(sysconfig.get_platform(), *sys.version_info[:2]))
@@ -31,7 +33,7 @@ update-constants: update-constants.py $(INCLUDE_DIR)/systemd/sd-messages.h
mv docs/id128.rst{.tmp,}
build:
- $(PYTHON) setup.py build_ext $(INCLUDE_FLAGS)
+ CFLAGS=$(CFLAGS) $(PYTHON) setup.py build_ext $(INCLUDE_FLAGS)
$(PYTHON) setup.py build
install: