summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2016-12-13 20:10:03 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2016-12-13 20:27:47 -0500
commitb4cfd41a06bfd4133d9359731eb637e221d179bf (patch)
tree829f5eb616540e1992c63a372bde6851263b98cb
parente4ff9e6f7cd1a5e1607803e805859c88545f4860 (diff)
downloadpython-systemd-b4cfd41a06bfd4133d9359731eb637e221d179bf.tar.gz
Makefile: use $(INCLUDE_DIR) also for compilation
This way we can compile against unreleased systemd: make PYTHON=python3 INCLUDE_DIR=/home/zbyszek/src/systemd/src (cd build/lib.linux-x86_64-3.5; systemd-socket-activate -E LD_LIBRARY_PATH=/home/zbyszek/src/systemd-master/.libs -l2000 -l127.0.0.1:2001 python3)
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b4923e3..290ac8a 100644
--- a/Makefile
+++ b/Makefile
@@ -31,6 +31,7 @@ update-constants: $(INCLUDE_DIR)/systemd/sd-messages.h
mv docs/id128.rst{.tmp,}
build:
+ $(PYTHON) setup.py build_ext $(if $(INCLUDE_DIR),-I$(INCLUDE_DIR))
$(PYTHON) setup.py build
install: