summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2016-09-22 09:59:04 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2016-09-22 09:59:04 -0400
commitc3c412f90e481b88ca897e8542ced207c445c757 (patch)
tree80a4c4487f80978b9422d192f90b84af8faba4b9
parentb9767792b97fe56b37bb59ee3d207ae359f1651c (diff)
downloadpython-systemd-c3c412f90e481b88ca897e8542ced207c445c757.tar.gz
build-sys: add doc-sync target
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index df0555c..23b452e 100644
--- a/Makefile
+++ b/Makefile
@@ -53,7 +53,11 @@ sphinx-%: build
check: build
(cd $(builddir) && $(PYTHON) -m py.test . ../../docs $(TESTFLAGS))
+www_target = www.freedesktop.org:/srv/www.freedesktop.org/www/software/systemd/python-systemd
+doc-sync:
+ rsync -rlv --delete --omit-dir-times build/html/ $(www_target)/
+
TAGS: $(shell git ls-files systemd/*.[ch])
$(ETAGS) $+
-.PHONY: build install dist clean distclean TAGS
+.PHONY: build install dist clean distclean TAGS doc-sync