summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-01-22 07:26:24 +1300
committerRobert Collins <robertc@robertcollins.net>2013-01-22 07:26:24 +1300
commit42e03ed5204c430079b9059e47fb52cfc3a1a2b3 (patch)
tree270408217c2c323d3ccb5e35b0dfbd49b375d9b7
parente0cfd656b7d1931bbd4d0e524948540c36471150 (diff)
downloadpython-test-extras-42e03ed5204c430079b9059e47fb52cfc3a1a2b3.tar.gz
Handle older testtools versions that are missing TestCommand.0.0.3
-rw-r--r--NEWS11
-rw-r--r--extras/__init__.py2
-rwxr-xr-xsetup.py8
3 files changed, 14 insertions, 7 deletions
diff --git a/NEWS b/NEWS
index a39cc76..60713b8 100644
--- a/NEWS
+++ b/NEWS
@@ -6,15 +6,22 @@ Changes and improvements to extras_, grouped by release.
NEXT
~~~~
+0.0.3
+~~~~~
+
+* Extras setup.py would break on older testtools releases, which could break
+ installs of newer testtools due to extras then failing to install.
+ (Robert Collins)
+
0.0.2
~~~~~
-Fix Makefile to not have cruft leftover from testtools.
+* Fix Makefile to not have cruft leftover from testtools.
0.0.1
~~~~~
-Initial extraction from testtools.
+* Initial extraction from testtools.
.. _extras: http://pypi.python.org/pypi/extras
diff --git a/extras/__init__.py b/extras/__init__.py
index f14ccc0..2d34b52 100644
--- a/extras/__init__.py
+++ b/extras/__init__.py
@@ -22,7 +22,7 @@ __all__ = [
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 0, 3, 'dev', 0)
+__version__ = (0, 0, 3, 'final', 0)
def try_import(name, alternative=None, error_callback=None):
diff --git a/setup.py b/setup.py
index c404979..c384a76 100755
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,11 @@
#!/usr/bin/env python
"""Distutils installer for extras."""
-from distutils.core import setup
+from setuptools import setup
import os.path
import extras
-testtools = extras.try_import('testtools')
+testtools_cmd = extras.try_import('testtools.TestCommand')
def get_version():
@@ -23,8 +23,8 @@ def get_long_description():
cmdclass = {}
-if testtools is not None:
- cmdclass['test'] = testtools.TestCommand
+if testtools_cmd is not None:
+ cmdclass['test'] = testtools_cmd
setup(name='extras',