summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index c404979..c384a76 100755
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,11 @@
#!/usr/bin/env python
"""Distutils installer for extras."""
-from distutils.core import setup
+from setuptools import setup
import os.path
import extras
-testtools = extras.try_import('testtools')
+testtools_cmd = extras.try_import('testtools.TestCommand')
def get_version():
@@ -23,8 +23,8 @@ def get_long_description():
cmdclass = {}
-if testtools is not None:
- cmdclass['test'] = testtools.TestCommand
+if testtools_cmd is not None:
+ cmdclass['test'] = testtools_cmd
setup(name='extras',