summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-01-22 07:26:24 +1300
committerRobert Collins <robertc@robertcollins.net>2013-01-22 07:26:24 +1300
commit42e03ed5204c430079b9059e47fb52cfc3a1a2b3 (patch)
tree270408217c2c323d3ccb5e35b0dfbd49b375d9b7 /setup.py
parente0cfd656b7d1931bbd4d0e524948540c36471150 (diff)
downloadpython-test-extras-42e03ed5204c430079b9059e47fb52cfc3a1a2b3.tar.gz
Handle older testtools versions that are missing TestCommand.0.0.3
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index c404979..c384a76 100755
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,11 @@
#!/usr/bin/env python
"""Distutils installer for extras."""
-from distutils.core import setup
+from setuptools import setup
import os.path
import extras
-testtools = extras.try_import('testtools')
+testtools_cmd = extras.try_import('testtools.TestCommand')
def get_version():
@@ -23,8 +23,8 @@ def get_long_description():
cmdclass = {}
-if testtools is not None:
- cmdclass['test'] = testtools.TestCommand
+if testtools_cmd is not None:
+ cmdclass['test'] = testtools_cmd
setup(name='extras',