summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Ross <jross@apache.org>2016-04-20 00:02:02 +0000
committerJustin Ross <jross@apache.org>2016-04-20 00:02:02 +0000
commita835fb2724824dcd8a470fb51424cedeb6b38f62 (patch)
tree48e5d8591c0029ac500330bf87b78bf9a99ed238
parentda7718ef463775acc7d6fbecf2d64c1bbfc39fd8 (diff)
downloadqpid-python-a835fb2724824dcd8a470fb51424cedeb6b38f62.tar.gz
QPID-7207: Rename and relocate files inside the cpp subtree
git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@1740034 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/CMakeLists.txt14
-rw-r--r--qpid/cpp/INSTALL-WINDOWS.txt (renamed from qpid/cpp/INSTALL-WINDOWS)0
-rw-r--r--qpid/cpp/INSTALL.txt (renamed from qpid/cpp/INSTALL)0
-rw-r--r--qpid/cpp/LICENSE.txt (renamed from qpid/cpp/LICENSE)0
-rw-r--r--qpid/cpp/NOTICE.txt (renamed from qpid/cpp/NOTICE)0
-rw-r--r--qpid/cpp/README.md59
-rw-r--r--qpid/cpp/README.txt68
-rw-r--r--qpid/cpp/RELEASE_NOTES9
-rw-r--r--qpid/cpp/VERSION.txt (renamed from qpid/cpp/QPID_VERSION.txt)0
-rw-r--r--qpid/cpp/docs/amqp-1.0.txt (renamed from qpid/cpp/AMQP_1.0)0
-rw-r--r--qpid/cpp/docs/design/CONTENTS (renamed from qpid/cpp/docs/src/CONTENTS)0
-rw-r--r--qpid/cpp/docs/design/DispatchHandle.odg (renamed from qpid/cpp/docs/src/DispatchHandle.odg)bin12481 -> 12481 bytes
-rw-r--r--qpid/cpp/docs/design/broker-acl-work.txt (renamed from qpid/cpp/design_docs/broker-acl-work.txt)0
-rw-r--r--qpid/cpp/docs/design/ha-transactions.md (renamed from qpid/cpp/design_docs/ha-transactions.md)0
-rw-r--r--qpid/cpp/docs/design/log-model-category-for-correlation.txt (renamed from qpid/cpp/design_docs/log-model-category-for-correlation.txt)0
-rw-r--r--qpid/cpp/docs/design/new-ha-design.txt (renamed from qpid/cpp/design_docs/new-ha-design.txt)0
-rw-r--r--qpid/cpp/docs/design/old-cluster-issues.txt (renamed from qpid/cpp/design_docs/old-cluster-issues.txt)0
-rw-r--r--qpid/cpp/docs/design/overview.txt (renamed from qpid/cpp/DESIGN)0
-rw-r--r--qpid/cpp/docs/design/windows_clfs_store_design.txt (renamed from qpid/cpp/design_docs/windows_clfs_store_design.txt)0
-rw-r--r--qpid/cpp/docs/ha.txt (renamed from qpid/cpp/README-HA.txt)0
-rw-r--r--qpid/cpp/docs/ssl.txt (renamed from qpid/cpp/SSL)0
-rw-r--r--qpid/cpp/packaging/winsdk/README.txt (renamed from qpid/cpp/README-winsdk.txt)0
-rw-r--r--qpid/cpp/packaging/winsdk/bld-winsdk.ps1 (renamed from qpid/cpp/bld-winsdk.ps1)0
23 files changed, 62 insertions, 88 deletions
diff --git a/qpid/cpp/CMakeLists.txt b/qpid/cpp/CMakeLists.txt
index 8a6c541c22..56f09c27c3 100644
--- a/qpid/cpp/CMakeLists.txt
+++ b/qpid/cpp/CMakeLists.txt
@@ -40,15 +40,7 @@ endif (CMAKE_CONFIGURATION_TYPES)
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMakeModules)
-# Parse the version from QPID_VERSION.txt.
-# Use the top level qpid/ file if we're in an SVN checkout, source dir otherwise.
-find_file(QPID_VERSION_FILE NAMES QPID_VERSION.txt PATHS ${PROJECT_SOURCE_DIR}/.. ${PROJECT_SOURCE_DIR} NO_DEFAULT_PATH)
-mark_as_advanced(QPID_VERSION_FILE)
-if(NOT QPID_VERSION_FILE)
- message(FATAL_ERROR "Cannot find QPID_VERSION.txt")
-endif(NOT QPID_VERSION_FILE)
-
-file(READ ${QPID_VERSION_FILE} QPID_VERSION)
+file(READ VERSION.txt QPID_VERSION)
string(REGEX REPLACE "^([0-9]+)\\.([0-9]+)\n" "\\1" QPID_VERSION_MAJOR "${QPID_VERSION}")
string(REGEX REPLACE "^([0-9]+)\\.([0-9]+)\n" "\\2" QPID_VERSION_MINOR "${QPID_VERSION}")
set (QPID_VERSION_FULL "${QPID_VERSION_MAJOR}.${QPID_VERSION_MINOR}")
@@ -71,7 +63,7 @@ endif (MSVC)
# Overall packaging/install options.
# This section also has all the setup for various packaging-specific options.
-set (CPACK_RESOURCE_FILE_LICENSE "${CMAKE_CURRENT_SOURCE_DIR}/LICENSE")
+set (CPACK_RESOURCE_FILE_LICENSE "${CMAKE_CURRENT_SOURCE_DIR}/LICENSE.txt")
if (WIN32)
# Include installing the MSVCRT library
set (CMAKE_INSTALL_DEBUG_LIBRARIES ON)
@@ -88,7 +80,7 @@ endif (WIN32)
set_absolute_install_path (QPIDC_CONF_FILE ${QPID_INSTALL_CONFDIR}/qpidc.conf)
set_absolute_install_path (QPIDD_CONF_FILE ${QPID_INSTALL_CONFDIR}/qpidd.conf)
-install(FILES LICENSE NOTICE DESTINATION ${QPID_INSTALL_DOCDIR})
+install(FILES LICENSE.txt NOTICE.txt DESTINATION ${QPID_INSTALL_DOCDIR})
install(FILES include/qmf/qmf2.i
DESTINATION ${QPID_INSTALL_INCLUDEDIR}/qmf)
diff --git a/qpid/cpp/INSTALL-WINDOWS b/qpid/cpp/INSTALL-WINDOWS.txt
index 64217196bc..64217196bc 100644
--- a/qpid/cpp/INSTALL-WINDOWS
+++ b/qpid/cpp/INSTALL-WINDOWS.txt
diff --git a/qpid/cpp/INSTALL b/qpid/cpp/INSTALL.txt
index 717c9b0908..717c9b0908 100644
--- a/qpid/cpp/INSTALL
+++ b/qpid/cpp/INSTALL.txt
diff --git a/qpid/cpp/LICENSE b/qpid/cpp/LICENSE.txt
index 6b0b1270ff..6b0b1270ff 100644
--- a/qpid/cpp/LICENSE
+++ b/qpid/cpp/LICENSE.txt
diff --git a/qpid/cpp/NOTICE b/qpid/cpp/NOTICE.txt
index c56cab3811..c56cab3811 100644
--- a/qpid/cpp/NOTICE
+++ b/qpid/cpp/NOTICE.txt
diff --git a/qpid/cpp/README.md b/qpid/cpp/README.md
new file mode 100644
index 0000000000..ba13a9f5ff
--- /dev/null
+++ b/qpid/cpp/README.md
@@ -0,0 +1,59 @@
+<!--
+
+Licensed to the Apache Software Foundation (ASF) under one
+or more contributor license agreements. See the NOTICE file
+distributed with this work for additional information
+regarding copyright ownership. The ASF licenses this file
+to you under the Apache License, Version 2.0 (the
+"License"); you may not use this file except in compliance
+with the License. You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing,
+software distributed under the License is distributed on an
+"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+KIND, either express or implied. See the License for the
+specific language governing permissions and limitations
+under the License.
+
+-->
+
+# Qpid C++
+
+## Introduction
+
+Qpid C++ is a C++ implementation of the AMQP protocol described at
+<http://amqp.org/>.
+
+For additional software or information on the Qpid project go to:
+
+> <http://qpid.apache.org>
+
+For documentation, go to:
+
+> <http://qpid.apache.org/documentation>
+
+## Available documentation
+
+ - INSTALL.txt - How to install Qpid C++
+ - LICENSE.txt - The Apache license
+ - NOTICE.txt - Corresponds to the section 4 d of the Apache License,
+ Version 2.0
+ - docs/ - Feature and design notes, other documentation
+
+## Quick start
+
+In C++ distributions:
+
+ mkdir BLD # The recommended way to use cmake is in a separate
+ # build directory
+ cd BLD
+ cmake .. # Generates code and makefiles
+ make test # Runs tests
+ make install # Installs the client and daemon
+
+The INSTALL.txt notes contain more detailed information on compiling
+and installing this software.
+
+qpid/cpp/examples/README.txt describes the C++ client API examples.
diff --git a/qpid/cpp/README.txt b/qpid/cpp/README.txt
deleted file mode 100644
index 0a62de1198..0000000000
--- a/qpid/cpp/README.txt
+++ /dev/null
@@ -1,68 +0,0 @@
-#
-# Licensed to the Apache Software Foundation (ASF) under one
-# or more contributor license agreements. See the NOTICE file
-# distributed with this work for additional information
-# regarding copyright ownership. The ASF licenses this file
-# to you under the Apache License, Version 2.0 (the
-# "License"); you may not use this file except in compliance
-# with the License. You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing,
-# software distributed under the License is distributed on an
-# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-# KIND, either express or implied. See the License for the
-# specific language governing permissions and limitations
-# under the License.
-#
-
- Qpid/C++
- ========
-
-Table of Contents
-=================
-1. Introduction
-2. Available Documentation
-3. Quick start
-
-
-1. Introduction
-===============
-Qpid/C++ is a C++ implementation of the AMQP protcol described at
-http://amqp.org/
-
-For additional software or information on the Qpid project go to:
-
- http://qpid.apache.org
-
-For documentation, go to:
-
- http://qpid.apache.org/documentation
-
-
-2. Available Documentation
-==========================
- - INSTALL - How to install Qpid/C++.
- - SSL - How to setup SSL
- - RELEASE_NOTES - Release notes.
- - DESIGN - Qpid/C++ implementation.
- - LICENSE - Apache license.
- - NOTICE - Corresponds to the section 4 d of
- the Apache License, Version 2.0.
-
-3. Quick start
-==============
-
-In C++ distributions:
-
- mkdir BLD # The recommended way to use cmake is in a separate build directory
- cd BLD
- cmake .. # Generates code and makefiles
- make test # Runs tests
- make install # Installs the client and daemon
-
-The INSTALL notes contain more detailed information on compiling and
-installing this software.
-
-qpid/cpp/examples/README.txt describes the C++ client API examples.
diff --git a/qpid/cpp/RELEASE_NOTES b/qpid/cpp/RELEASE_NOTES
deleted file mode 100644
index a8995c6039..0000000000
--- a/qpid/cpp/RELEASE_NOTES
+++ /dev/null
@@ -1,9 +0,0 @@
-Apache Qpid Release Notes
---------------------------------
-
-Please see:
-
-http://qpid.apache.org/releases/
-
-for information about this release and other related Qpid component
-current and past releases.
diff --git a/qpid/cpp/QPID_VERSION.txt b/qpid/cpp/VERSION.txt
index c74e8a041a..c74e8a041a 100644
--- a/qpid/cpp/QPID_VERSION.txt
+++ b/qpid/cpp/VERSION.txt
diff --git a/qpid/cpp/AMQP_1.0 b/qpid/cpp/docs/amqp-1.0.txt
index 0e811a68f5..0e811a68f5 100644
--- a/qpid/cpp/AMQP_1.0
+++ b/qpid/cpp/docs/amqp-1.0.txt
diff --git a/qpid/cpp/docs/src/CONTENTS b/qpid/cpp/docs/design/CONTENTS
index cc3b868e0e..cc3b868e0e 100644
--- a/qpid/cpp/docs/src/CONTENTS
+++ b/qpid/cpp/docs/design/CONTENTS
diff --git a/qpid/cpp/docs/src/DispatchHandle.odg b/qpid/cpp/docs/design/DispatchHandle.odg
index c08b3a4e1a..c08b3a4e1a 100644
--- a/qpid/cpp/docs/src/DispatchHandle.odg
+++ b/qpid/cpp/docs/design/DispatchHandle.odg
Binary files differ
diff --git a/qpid/cpp/design_docs/broker-acl-work.txt b/qpid/cpp/docs/design/broker-acl-work.txt
index e587dc5198..e587dc5198 100644
--- a/qpid/cpp/design_docs/broker-acl-work.txt
+++ b/qpid/cpp/docs/design/broker-acl-work.txt
diff --git a/qpid/cpp/design_docs/ha-transactions.md b/qpid/cpp/docs/design/ha-transactions.md
index bfa5456a2c..bfa5456a2c 100644
--- a/qpid/cpp/design_docs/ha-transactions.md
+++ b/qpid/cpp/docs/design/ha-transactions.md
diff --git a/qpid/cpp/design_docs/log-model-category-for-correlation.txt b/qpid/cpp/docs/design/log-model-category-for-correlation.txt
index 280f53bb9d..280f53bb9d 100644
--- a/qpid/cpp/design_docs/log-model-category-for-correlation.txt
+++ b/qpid/cpp/docs/design/log-model-category-for-correlation.txt
diff --git a/qpid/cpp/design_docs/new-ha-design.txt b/qpid/cpp/docs/design/new-ha-design.txt
index df6c7242eb..df6c7242eb 100644
--- a/qpid/cpp/design_docs/new-ha-design.txt
+++ b/qpid/cpp/docs/design/new-ha-design.txt
diff --git a/qpid/cpp/design_docs/old-cluster-issues.txt b/qpid/cpp/docs/design/old-cluster-issues.txt
index c552a67c9a..c552a67c9a 100644
--- a/qpid/cpp/design_docs/old-cluster-issues.txt
+++ b/qpid/cpp/docs/design/old-cluster-issues.txt
diff --git a/qpid/cpp/DESIGN b/qpid/cpp/docs/design/overview.txt
index f44aa8a5af..f44aa8a5af 100644
--- a/qpid/cpp/DESIGN
+++ b/qpid/cpp/docs/design/overview.txt
diff --git a/qpid/cpp/design_docs/windows_clfs_store_design.txt b/qpid/cpp/docs/design/windows_clfs_store_design.txt
index 944d957083..944d957083 100644
--- a/qpid/cpp/design_docs/windows_clfs_store_design.txt
+++ b/qpid/cpp/docs/design/windows_clfs_store_design.txt
diff --git a/qpid/cpp/README-HA.txt b/qpid/cpp/docs/ha.txt
index 106d20c24f..106d20c24f 100644
--- a/qpid/cpp/README-HA.txt
+++ b/qpid/cpp/docs/ha.txt
diff --git a/qpid/cpp/SSL b/qpid/cpp/docs/ssl.txt
index 65f4577ab2..65f4577ab2 100644
--- a/qpid/cpp/SSL
+++ b/qpid/cpp/docs/ssl.txt
diff --git a/qpid/cpp/README-winsdk.txt b/qpid/cpp/packaging/winsdk/README.txt
index 808d089174..808d089174 100644
--- a/qpid/cpp/README-winsdk.txt
+++ b/qpid/cpp/packaging/winsdk/README.txt
diff --git a/qpid/cpp/bld-winsdk.ps1 b/qpid/cpp/packaging/winsdk/bld-winsdk.ps1
index fb66b74118..fb66b74118 100644
--- a/qpid/cpp/bld-winsdk.ps1
+++ b/qpid/cpp/packaging/winsdk/bld-winsdk.ps1