summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2017-10-10 23:43:55 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2017-10-10 23:43:55 -0700
commit5876a8e9b2e1b57e802f7ac5daa17ab2f24d2ae0 (patch)
tree95e743992d91f05b2dddb8245e3c98ecdc907ef6
parent9171f787631ec8d296ea7225e018d659f0703b2c (diff)
downloadrabbitmq-c-5876a8e9b2e1b57e802f7ac5daa17ab2f24d2ae0.tar.gz
build: remove obsolete HAVE_HTONLL check
HAVE_HTONLL was used for the byteswap code, which no longer uses htonll, this can be removed.
-rw-r--r--CMakeLists.txt9
-rw-r--r--cmake/config.h.in2
2 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e623a9..892eae9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,15 +98,6 @@ cmake_pop_check_state()
cmake_push_check_state()
set(CMAKE_REQUIRED_LIBRARIES ${SOCKET_LIBRARIES})
-if (WIN32)
- check_symbol_exists(htonll Winsock2.h HAVE_HTONLL)
-else (WIN32)
- check_symbol_exists(htonll arpa/inet.h HAVE_HTONLL)
-endif (WIN32)
-cmake_pop_check_state()
-
-cmake_push_check_state()
-set(CMAKE_REQUIRED_LIBRARIES ${SOCKET_LIBRARIES})
check_symbol_exists(poll poll.h HAVE_POLL)
if (NOT HAVE_POLL)
if (WIN32)
diff --git a/cmake/config.h.in b/cmake/config.h.in
index a7e5a2c..34cb9b2 100644
--- a/cmake/config.h.in
+++ b/cmake/config.h.in
@@ -6,8 +6,6 @@
# define inline ${C_INLINE_KEYWORD}
#endif
-#cmakedefine HAVE_HTONLL
-
#cmakedefine HAVE_SELECT
#cmakedefine HAVE_POLL