summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-19 22:41:03 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-04-19 17:58:33 -0700
commit633d5fd10a2782968783c0bb58b3e88b8978c567 (patch)
tree1cec3485e962cc9fb7a0efd426aee1a37b66b78a /CMakeLists.txt
parent22bc57506e4184e945169bab56c3781ed8f898d4 (diff)
downloadrabbitmq-c-633d5fd10a2782968783c0bb58b3e88b8978c567.tar.gz
cmake: rename FindXMLTO.cmake to correct warning
CMake issues the following developer warning about FindXmlTo: The package name passed to `find_package_handle_standard_args` (XMLTO) does not match the name of the calling package (XmlTo). This can lead to problems in calling code that expects `find_package` result variables (e.g., `_FOUND`) to follow a certain pattern. This corrects that by naming it FindXMLTO.cmake. Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e821784..2c26829 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -253,8 +253,8 @@ endif()
if(BUILD_TOOLS)
find_package(POPT REQUIRED)
- if(BUILD_TOOL_DOCS)
- find_package(XmlTo REQUIRED)
+ if(BUILD_TOOLS_DOCS)
+ find_package(XMLTO REQUIRED)
endif()
add_subdirectory(tools)
endif()