summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-07 05:26:00 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-04-06 22:40:58 -0700
commit85a51d01fa7712ff42a6fcb432c2821fe9583459 (patch)
tree671aa9b9e9609e262e6a4901759d5123f1c5f0b8 /CMakeLists.txt
parent5d1fd824227f8eb20b1ac2eb63d6533d7479556a (diff)
downloadrabbitmq-c-85a51d01fa7712ff42a6fcb432c2821fe9583459.tar.gz
ssl: drop support OpenSSL v1.1.0 and older
v1.1.0 and older is no longer supported by OpenSSL (https://www.openssl.org/policies/releasestrat.html). While there is the possibility that someone is paying for support for v1.0.2, this library is not regularly tested against these versions. As a side-effect older workarounds for hostname verification can be removed. Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 428b1e5..9752984 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,7 +112,7 @@ endif()
option(ENABLE_SSL_SUPPORT "Enable SSL support" ON)
if (ENABLE_SSL_SUPPORT)
- find_package(OpenSSL 0.9.8 REQUIRED)
+ find_package(OpenSSL 1.1.1 REQUIRED)
cmake_push_check_state()
set(THREADS_PREFER_PTHREAD_FLAG ON)