summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-01 19:20:18 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-04-01 12:29:05 -0700
commit8bdbd0343e69d00b5229386a5da0a54a336a28f6 (patch)
treefc2abc600e19e213c94958e7726d0b916aa1c7c5 /CMakeLists.txt
parent20bebf423bd3686fe73634ae239d09e5d21abde4 (diff)
downloadrabbitmq-c-8bdbd0343e69d00b5229386a5da0a54a336a28f6.tar.gz
cmake: restore -fvisibility=hidden flag
This removed when the manual flag manipulation bit was removed. This restores the previous behavior and adds -fvisibility-inlines-hidden Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74364cf..473642a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,10 @@ project(rabbitmq-c "C")
set(CMAKE_C_STANDARD 90)
set(CMAKE_C_STANDARD_REQUIRED ON)
-SET(CMAKE_C_EXTENSIONS ON)
+set(CMAKE_C_EXTENSIONS ON)
+
+set(CMAKE_C_VISIBILITY_PRESET hidden)
+set(CMAKE_VISIBILITY_INLINES_HIDDEN ON)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)