summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorTony Garnock-Jones <tonyg@kcbbs.gen.nz>2009-04-30 00:08:51 +0100
committerTony Garnock-Jones <tonyg@kcbbs.gen.nz>2009-04-30 00:08:51 +0100
commit107d08b387e3f43aed3e11465c6c0cca64f89b4a (patch)
treec3b03096e23ed1932c04ddb1312c94a15159a1cf /examples
parent5ad7fc306e8a6fb18222a502b8881f39384c4076 (diff)
downloadrabbitmq-c-107d08b387e3f43aed3e11465c6c0cca64f89b4a.tar.gz
Simple producer/consumer examples
Diffstat (limited to 'examples')
-rw-r--r--examples/Makefile.am4
-rw-r--r--examples/amqp_consumer.c172
-rw-r--r--examples/amqp_producer.c104
-rw-r--r--examples/example_utils.c7
-rw-r--r--examples/example_utils.h2
5 files changed, 288 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 45f0308..dbb7953 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,4 +1,4 @@
-bin_PROGRAMS = amqp_sendstring amqp_exchange_declare amqp_listen
+bin_PROGRAMS = amqp_sendstring amqp_exchange_declare amqp_listen amqp_producer amqp_consumer
AM_CFLAGS = -I../librabbitmq
AM_LDFLAGS = ../librabbitmq/librabbitmq.la
@@ -8,3 +8,5 @@ nodist_INCLUDES = example_utils.h
amqp_sendstring_SOURCES = amqp_sendstring.c example_utils.c
amqp_exchange_declare_SOURCES = amqp_exchange_declare.c example_utils.c
amqp_listen_SOURCES = amqp_listen.c example_utils.c
+amqp_producer_SOURCES = amqp_producer.c example_utils.c
+amqp_consumer_SOURCES = amqp_consumer.c example_utils.c
diff --git a/examples/amqp_consumer.c b/examples/amqp_consumer.c
new file mode 100644
index 0000000..84c3669
--- /dev/null
+++ b/examples/amqp_consumer.c
@@ -0,0 +1,172 @@
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+#include <errno.h>
+
+#include <stdint.h>
+#include <amqp.h>
+#include <amqp_framing.h>
+
+#include <unistd.h>
+#include <assert.h>
+
+#include "example_utils.h"
+
+#define SUMMARY_EVERY_US 1000000
+
+static void run(amqp_connection_state_t conn)
+{
+ long long start_time = now_microseconds();
+ int received = 0;
+ int previous_received = 0;
+ long long previous_report_time = start_time;
+ long long next_summary_time = start_time + SUMMARY_EVERY_US;
+
+ amqp_frame_t frame;
+ int result;
+ size_t body_received;
+ size_t body_target;
+
+ long long now;
+
+ while (1) {
+ now = now_microseconds();
+ if (now > next_summary_time) {
+ int countOverInterval = received - previous_received;
+ double intervalRate = countOverInterval / ((now - previous_report_time) / 1000000.0);
+ printf("%lld ms: Received %d - %d since last report (%d Hz)\n",
+ (now - start_time) / 1000, received, countOverInterval, (int) intervalRate);
+
+ previous_received = received;
+ previous_report_time = now;
+ next_summary_time += SUMMARY_EVERY_US;
+ }
+
+ amqp_maybe_release_buffers(conn);
+ result = amqp_simple_wait_frame(conn, &frame);
+ if (result <= 0) return;
+
+ if (frame.frame_type != AMQP_FRAME_METHOD)
+ continue;
+
+ if (frame.payload.method.id != AMQP_BASIC_DELIVER_METHOD)
+ continue;
+
+ result = amqp_simple_wait_frame(conn, &frame);
+ if (result <= 0) return;
+ if (frame.frame_type != AMQP_FRAME_HEADER) {
+ fprintf(stderr, "Expected header!");
+ abort();
+ }
+
+ body_target = frame.payload.properties.body_size;
+ body_received = 0;
+
+ while (body_received < body_target) {
+ result = amqp_simple_wait_frame(conn, &frame);
+ if (result <= 0) return;
+
+ if (frame.frame_type != AMQP_FRAME_BODY) {
+ fprintf(stderr, "Expected body!");
+ abort();
+ }
+
+ body_received += frame.payload.body_fragment.len;
+ assert(body_received <= body_target);
+ }
+
+ received++;
+ }
+}
+
+int main(int argc, char const * const *argv) {
+ char const *hostname;
+ int port;
+ char const *exchange;
+ char const *bindingkey;
+
+ int sockfd;
+ amqp_connection_state_t conn;
+
+ amqp_rpc_reply_t result;
+ amqp_bytes_t queuename;
+
+ if (argc < 3) {
+ fprintf(stderr, "Usage: amqp_consumer host port\n");
+ return 1;
+ }
+
+ hostname = argv[1];
+ port = atoi(argv[2]);
+ exchange = ""; //argv[3];
+ bindingkey = "test queue"; //argv[4];
+
+ conn = amqp_new_connection();
+
+ die_on_error(sockfd = amqp_open_socket(hostname, port), "Opening socket");
+ amqp_set_sockfd(conn, sockfd);
+ die_on_amqp_error(amqp_login(conn, "/", 131072, AMQP_SASL_METHOD_PLAIN, "guest", "guest"),
+ "Logging in");
+
+ {
+ amqp_queue_declare_t s =
+ (amqp_queue_declare_t) {
+ .ticket = 0,
+ .queue = {.len = 0, .bytes = NULL},
+ .passive = 0,
+ .durable = 0,
+ .exclusive = 0,
+ .auto_delete = 1,
+ .nowait = 0,
+ .arguments = {.num_entries = 0, .entries = NULL}
+ };
+ die_on_amqp_error(result = amqp_simple_rpc(conn, 1, AMQP_QUEUE_DECLARE_METHOD,
+ AMQP_QUEUE_DECLARE_OK_METHOD, &s),
+ "Declaring queue");
+ amqp_queue_declare_ok_t *r = (amqp_queue_declare_ok_t *) result.reply.decoded;
+ queuename = amqp_bytes_malloc_dup(r->queue);
+ if (queuename.bytes == NULL) {
+ die_on_error(-ENOMEM, "Copying queue name");
+ }
+ }
+
+ {
+ amqp_queue_bind_t s =
+ (amqp_queue_bind_t) {
+ .ticket = 0,
+ .queue = queuename,
+ .exchange = amqp_cstring_bytes(exchange),
+ .routing_key = amqp_cstring_bytes(bindingkey),
+ .nowait = 0,
+ .arguments = {.num_entries = 0, .entries = NULL}
+ };
+ die_on_amqp_error(result = amqp_simple_rpc(conn, 1, AMQP_QUEUE_BIND_METHOD,
+ AMQP_QUEUE_BIND_OK_METHOD, &s),
+ "Binding queue");
+ }
+
+ {
+ amqp_basic_consume_t s =
+ (amqp_basic_consume_t) {
+ .ticket = 0,
+ .queue = queuename,
+ .consumer_tag = {.len = 0, .bytes = NULL},
+ .no_local = 0,
+ .no_ack = 1,
+ .exclusive = 0,
+ .nowait = 0
+ };
+ die_on_amqp_error(result = amqp_simple_rpc(conn, 1, AMQP_BASIC_CONSUME_METHOD,
+ AMQP_BASIC_CONSUME_OK_METHOD, &s),
+ "Consuming");
+ }
+
+ run(conn);
+
+ die_on_amqp_error(amqp_channel_close(conn, AMQP_REPLY_SUCCESS), "Closing channel");
+ die_on_amqp_error(amqp_connection_close(conn, AMQP_REPLY_SUCCESS), "Closing connection");
+ amqp_destroy_connection(conn);
+ die_on_error(close(sockfd), "Closing socket");
+
+ return 0;
+}
diff --git a/examples/amqp_producer.c b/examples/amqp_producer.c
new file mode 100644
index 0000000..ef270b1
--- /dev/null
+++ b/examples/amqp_producer.c
@@ -0,0 +1,104 @@
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+
+#include <stdint.h>
+#include <amqp.h>
+#include <amqp_framing.h>
+
+#include <unistd.h>
+
+#include "example_utils.h"
+
+#define SUMMARY_EVERY_US 1000000
+
+static void send_batch(amqp_connection_state_t conn,
+ char const *queue_name,
+ int rate_limit,
+ int message_count)
+{
+ long long start_time = now_microseconds();
+ int i;
+ int sent = 0;
+ int previous_sent = 0;
+ long long previous_report_time = start_time;
+ long long next_summary_time = start_time + SUMMARY_EVERY_US;
+
+ char message[256];
+
+ for (i = 0; i < sizeof(message); i++) {
+ message[i] = i & 0xff;
+ }
+
+ for (i = 0; i < message_count; i++) {
+ long long now = now_microseconds();
+ die_on_error(amqp_basic_publish(conn,
+ (amqp_bytes_t) {.len = 0},
+ amqp_cstring_bytes(queue_name),
+ 0,
+ 0,
+ NULL,
+ (amqp_bytes_t) {.len = sizeof(message), .bytes = message}),
+ "Publishing");
+ sent++;
+ if (now > next_summary_time) {
+ int countOverInterval = sent - previous_sent;
+ double intervalRate = countOverInterval / ((now - previous_report_time) / 1000000.0);
+ printf("%lld ms: Sent %d - %d since last report (%d Hz)\n",
+ (now - start_time) / 1000, sent, countOverInterval, (int) intervalRate);
+
+ previous_sent = sent;
+ previous_report_time = now;
+ next_summary_time += SUMMARY_EVERY_US;
+ }
+
+ while (((i * 1000000.0) / (now - start_time)) > rate_limit) {
+ usleep(2000);
+ now = now_microseconds();
+ }
+ }
+
+ {
+ long long stop_time = now_microseconds();
+ long long total_delta = stop_time - start_time;
+
+ printf("PRODUCER - Message count: %d\n", message_count);
+ printf("Total time, milliseconds: %lld\n", total_delta / 1000);
+ printf("Overall messages-per-second: %g\n", (message_count / (total_delta / 1000000.0)));
+ }
+}
+
+int main(int argc, char const * const *argv) {
+ char const *hostname;
+ int port;
+ int rate_limit;
+ int message_count;
+
+ int sockfd;
+ amqp_connection_state_t conn;
+
+ if (argc < 5) {
+ fprintf(stderr, "Usage: amqp_producer host port rate_limit message_count\n");
+ return 1;
+ }
+
+ hostname = argv[1];
+ port = atoi(argv[2]);
+ rate_limit = atoi(argv[3]);
+ message_count = atoi(argv[4]);
+
+ conn = amqp_new_connection();
+
+ die_on_error(sockfd = amqp_open_socket(hostname, port), "Opening socket");
+ amqp_set_sockfd(conn, sockfd);
+ die_on_amqp_error(amqp_login(conn, "/", 131072, AMQP_SASL_METHOD_PLAIN, "guest", "guest"),
+ "Logging in");
+
+ send_batch(conn, "test queue", rate_limit, message_count);
+
+ die_on_amqp_error(amqp_channel_close(conn, AMQP_REPLY_SUCCESS), "Closing channel");
+ die_on_amqp_error(amqp_connection_close(conn, AMQP_REPLY_SUCCESS), "Closing connection");
+ amqp_destroy_connection(conn);
+ die_on_error(close(sockfd), "Closing socket");
+ return 0;
+}
diff --git a/examples/example_utils.c b/examples/example_utils.c
index 7c01074..de6694d 100644
--- a/examples/example_utils.c
+++ b/examples/example_utils.c
@@ -6,6 +6,7 @@
#include <amqp.h>
#include <amqp_framing.h>
+#include <sys/time.h>
#include <unistd.h>
void die_on_error(int x, char const *context) {
@@ -55,3 +56,9 @@ void die_on_amqp_error(amqp_rpc_reply_t x, char const *context) {
exit(1);
}
+
+long long now_microseconds(void) {
+ struct timeval tv;
+ gettimeofday(&tv, NULL);
+ return (long long) tv.tv_sec * 1000000 + (long long) tv.tv_usec;
+}
diff --git a/examples/example_utils.h b/examples/example_utils.h
index eda03e7..72d3b9d 100644
--- a/examples/example_utils.h
+++ b/examples/example_utils.h
@@ -4,4 +4,6 @@
extern void die_on_error(int x, char const *context);
extern void die_on_amqp_error(amqp_rpc_reply_t x, char const *context);
+extern long long now_microseconds(void);
+
#endif