summaryrefslogtreecommitdiff
path: root/.readthedocs.yml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-03-03 09:51:15 -0600
committerJordan Cook <jordan.cook@pioneer.com>2021-03-03 09:54:03 -0600
commitc25514312bafb89fe86663c0112d478714d1f83e (patch)
tree0fa644c396f4339b39aa24c318841e2ac2429182 /.readthedocs.yml
parent9ae36967367c6bf4789d42b66f59ceb481e1b834 (diff)
downloadrequests-cache-c25514312bafb89fe86663c0112d478714d1f83e.tar.gz
Documentation build improvments:
* Add `.readthedocs.yml` build config * Remove mocks for backend modules (pymongo, redis-py, etc.), and make Readthedocs install them before building * Add Sphinx extensions for: * Google-style docstrings * 'Copy' button for code snippets * Automatic type annotation docs * Links to view source code * Add documentation requirements to setup.py for building docs locally * Remove config for unused Sphinx outputs
Diffstat (limited to '.readthedocs.yml')
-rw-r--r--.readthedocs.yml16
1 files changed, 16 insertions, 0 deletions
diff --git a/.readthedocs.yml b/.readthedocs.yml
new file mode 100644
index 0000000..15bc7c5
--- /dev/null
+++ b/.readthedocs.yml
@@ -0,0 +1,16 @@
+# Read the Docs configuration file
+version: 2
+
+sphinx:
+ builder: html
+ configuration: docs/conf.py
+
+python:
+ version: 3.7
+ system_packages: True
+ install:
+ - method: pip
+ path: .
+ extra_requirements:
+ - docs
+ - backends