summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 14:05:42 +0200
committerSybren A. Stüvel <sybren@stuvel.eu>2019-08-04 14:15:39 +0200
commit1e22d2eb03c7a29a0befe1febf951af9e46ce470 (patch)
treebb930d3711b877a6ce84670287358bcae8ac0d48 /doc
parent7424c69bde598a145b7d3807e6c367ac4b922bff (diff)
downloadrsa-git-1e22d2eb03c7a29a0befe1febf951af9e46ce470.tar.gz
Drop support for Python 2 and 3.4
Some of our development dependencies, like Sphinx, have already dropped support for Python 2. This makes it harder for this project to update its dependencies. Since Python 2 only has a few more months to live, I think it's fine to drop support now. Python 3.4 has already reached its end-of-life date. Python-RSA now only supports Python 3.5 and newer. Python 3.5 support is intended to last until its end-of-life date of 2019-09-13: https://devguide.python.org/#status-of-python-branches
Diffstat (limited to 'doc')
-rw-r--r--doc/installation.rst24
1 files changed, 12 insertions, 12 deletions
diff --git a/doc/installation.rst b/doc/installation.rst
index 32dc257..e8f7170 100644
--- a/doc/installation.rst
+++ b/doc/installation.rst
@@ -1,13 +1,13 @@
Installation
============
-Installation can be done in various ways. The simplest form uses pip
-or easy_install. Either one will work::
+Installation can be done in various ways. The simplest form uses pip::
pip install rsa
Depending on your system you may need to use ``sudo pip`` if you want to install
-the library system-wide.
+the library system-wide, or use ``pip install --user rsa`` to install the
+library in your home directory.
Installation from source is also quite easy. Download the source and
then type::
@@ -25,6 +25,9 @@ GitHub. It also hosts the `issue tracker`_.
Dependencies
------------
+Python-RSA is compatible with Python versions 3.5 and newer. The last
+version with Python 2.7 support was Python-RSA 4.0.
+
Python-RSA has very few dependencies. As a matter of fact, to use it
you only need Python itself. Loading and saving keys does require an
extra module, though: pyasn1. If you used pip or easy_install like
@@ -34,17 +37,14 @@ described above, you should be ready to go.
Development dependencies
------------------------
-In order to start developing on Python-RSA you need a bit more. Use
-pip to install the development requirements in a virtual environment::
-
- virtualenv -p /path/to/your-python-version python-rsa-venv
- . python-rsa-venv/bin/activate
- pip install -r python-rsa/requirements.txt
+In order to start developing on Python-RSA, use Git_ to get a copy of
+the source::
+ git clone https://github.com/sybrenstuvel/python-rsa.git
-Once these are installed, use Git_ to get a copy of the source::
+Use pipenv_ to install the development requirements in a virtual environment::
- git clone https://github.com/sybrenstuvel/python-rsa.git
- python setup.py develop
+ pipenv install --dev
.. _Git: https://git-scm.com/
+.. _pipenv: https://docs.pipenv.org/