summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-01-15 09:20:26 +0100
committerAnthon van der Neut <anthon@mnt.org>2015-01-15 09:20:26 +0100
commit731d95c892e3cf1d6cb8c42764eb7bcbe358bd54 (patch)
tree219473408864ef882dd70701f14e9670d456a54a
parent6a631a7a975d418c6a7afd7e8ecf61d851a8636d (diff)
downloadruamel.std.argparse-731d95c892e3cf1d6cb8c42764eb7bcbe358bd54.tar.gz
- removed remnants of creating __init__.py
- test for py26 failed if element was hashed to last place
-rw-r--r--__init__.py2
-rw-r--r--setup.py22
-rw-r--r--test/test_program.py2
3 files changed, 2 insertions, 24 deletions
diff --git a/__init__.py b/__init__.py
index a952b7a..f9058ce 100644
--- a/__init__.py
+++ b/__init__.py
@@ -33,7 +33,7 @@ def _convert_version(tup):
# <
-version_info = (0, 5, 1)
+version_info = (0, 5, 2)
__version__ = _convert_version(version_info)
del _convert_version
diff --git a/setup.py b/setup.py
index fc56484..b6a712d 100644
--- a/setup.py
+++ b/setup.py
@@ -75,28 +75,6 @@ class MyInstallLib(install_lib.install_lib):
"create __init__.py on the fly"
def run(self):
install_lib.install_lib.run(self)
- return
- init_txt = dedent('''\y
- # coding: utf-8
- # Copyright © 2013-2014 Anthon van der Neut, RUAMEL bvba
- "generated __init__.py "
- try:
- __import__('pkg_resources').declare_namespace(__name__)
- except ImportError:
- pass
- ''')
- init_path = full_package_name.split('.')[:-1]
- for product_init in [
- os.path.join(
- *([self.install_dir] + init_path[:p+1] + ['__init__.py']))
- for p in range(len(init_path))
- ]:
- if not os.path.exists(product_init):
- raise NotImplementedError
- print('creating %s' % product_init)
- with open(product_init, "w") as fp:
- fp.write(init_txt)
- setup = os.path.join(self.install_dir, 'setup.py')
def install(self):
fpp = full_package_name.split('.') # full package path
diff --git a/test/test_program.py b/test/test_program.py
index fa6320b..4487b65 100644
--- a/test/test_program.py
+++ b/test/test_program.py
@@ -157,7 +157,7 @@ class ParseHelpOutput:
for l in self._chunks[chunk]:
start_idx = l.find('{')
end_idx = l.find('}')
- test_elems = l[start_idx + 1:end_idx-1].split(',')
+ test_elems = l[start_idx + 1:end_idx].split(',')
for elem in elems:
if elem not in test_elems:
break