summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-01-15 09:20:26 +0100
committerAnthon van der Neut <anthon@mnt.org>2015-01-15 09:20:26 +0100
commit731d95c892e3cf1d6cb8c42764eb7bcbe358bd54 (patch)
tree219473408864ef882dd70701f14e9670d456a54a /setup.py
parent6a631a7a975d418c6a7afd7e8ecf61d851a8636d (diff)
downloadruamel.std.argparse-731d95c892e3cf1d6cb8c42764eb7bcbe358bd54.tar.gz
- removed remnants of creating __init__.py
- test for py26 failed if element was hashed to last place
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 0 insertions, 22 deletions
diff --git a/setup.py b/setup.py
index fc56484..b6a712d 100644
--- a/setup.py
+++ b/setup.py
@@ -75,28 +75,6 @@ class MyInstallLib(install_lib.install_lib):
"create __init__.py on the fly"
def run(self):
install_lib.install_lib.run(self)
- return
- init_txt = dedent('''\y
- # coding: utf-8
- # Copyright © 2013-2014 Anthon van der Neut, RUAMEL bvba
- "generated __init__.py "
- try:
- __import__('pkg_resources').declare_namespace(__name__)
- except ImportError:
- pass
- ''')
- init_path = full_package_name.split('.')[:-1]
- for product_init in [
- os.path.join(
- *([self.install_dir] + init_path[:p+1] + ['__init__.py']))
- for p in range(len(init_path))
- ]:
- if not os.path.exists(product_init):
- raise NotImplementedError
- print('creating %s' % product_init)
- with open(product_init, "w") as fp:
- fp.write(init_txt)
- setup = os.path.join(self.install_dir, 'setup.py')
def install(self):
fpp = full_package_name.split('.') # full package path