summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2016-01-30 23:34:21 +0100
committerAnthon van der Neut <anthon@mnt.org>2016-01-30 23:34:21 +0100
commit720b785274718800ffd67bbc2f4a7cbbc1e3bd21 (patch)
treeb28af46d0492a834ea12f1f8f5d2b4f0bb03a4bb /setup.py
parent8a8bcbf4f4d1bf9b5cf76dd40cfb941edc03917b (diff)
downloadruamel.yaml-720b785274718800ffd67bbc2f4a7cbbc1e3bd21.tar.gz
util versions
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 818723c..c6e6bff 100644
--- a/setup.py
+++ b/setup.py
@@ -593,6 +593,8 @@ class NameSpacePackager(object):
print("\n\n>>>>>> LICENSE file not found <<<<<\n\n")
if self._pkg_data.get('universal'):
fp.write('[bdist_wheel]\nuniversal = 1\n')
+ else:
+ fp.write('[bdist_wheel]\nuniversal = 0\n')
try:
setup(**kw)
except:
@@ -609,6 +611,12 @@ class BinaryDistribution(Distribution):
# # call setup
def main():
+ if '--version' not in sys.argv:
+ import wheel
+ import distutils
+ print('python: ', sys.version)
+ print('distutils:', distutils.__version__)
+ print('wheel: ', wheel.__version__)
nsp = NameSpacePackager(pkg_data)
nsp.check()
nsp.create_dirs()