summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2016-01-30 23:07:24 +0100
committerAnthon van der Neut <anthon@mnt.org>2016-01-30 23:07:24 +0100
commit8a8bcbf4f4d1bf9b5cf76dd40cfb941edc03917b (patch)
tree8dc420280878e9949ffe324c2c357b17bd800442 /setup.py
parent58ffc1af993823a3862d90cbc7b636c88e44ab46 (diff)
downloadruamel.yaml-8a8bcbf4f4d1bf9b5cf76dd40cfb941edc03917b.tar.gz
explicit BinaryDistribution class
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e117347..818723c 100644
--- a/setup.py
+++ b/setup.py
@@ -602,6 +602,11 @@ class NameSpacePackager(object):
return True
+class BinaryDistribution(Distribution):
+ def is_pure(self):
+ return False
+
+
# # call setup
def main():
nsp = NameSpacePackager(pkg_data)
@@ -624,6 +629,7 @@ def main():
classifiers=nsp.classifiers,
package_data=nsp.package_data,
ext_modules=nsp.ext_modules,
+ distclass=BinaryDistribution,
)
if '--version' not in sys.argv and '--verbose' in sys.argv:
for k in sorted(kw):