summaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorTakeshi KOMIYA <i.tkomiya@gmail.com>2020-02-23 16:51:35 +0900
committerGitHub <noreply@github.com>2020-02-23 16:51:35 +0900
commit27dc91165033dcbca0363c06a1585178fe0348d6 (patch)
treeda0bffd6992d8be157ef0ecd85c96d45bf57e3b3 /utils
parent4f0e83306e9a228399e5a1361eb8aba3d3cc01b5 (diff)
parent5572eb7b9ea3e761c74688c73e60d2749144a87f (diff)
downloadsphinx-git-27dc91165033dcbca0363c06a1585178fe0348d6.tar.gz
Merge pull request #7204 from tk0miya/clean_dists_on_make_clean
Makefile: clean dists directory on "make clean"
Diffstat (limited to 'utils')
-rw-r--r--utils/release-checklist16
1 files changed, 8 insertions, 8 deletions
diff --git a/utils/release-checklist b/utils/release-checklist
index fa09f9e8b..679983283 100644
--- a/utils/release-checklist
+++ b/utils/release-checklist
@@ -12,8 +12,8 @@ for stable releases
* ``git commit -am 'Bump to X.Y.Z final'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.Z``
* ``python utils/bump_version.py --in-develop X.Y.Zb0`` (ex. 1.5.3b0)
@@ -39,8 +39,8 @@ for first beta releases
* ``git commit -am 'Bump to X.Y.0 beta1'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.0b1``
* ``python utils/bump_version.py --in-develop X.Y.0b2`` (ex. 1.6.0b2)
@@ -69,8 +69,8 @@ for other beta releases
* ``git commit -am 'Bump to X.Y.0 betaN'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.0bN``
* ``python utils/bump_version.py --in-develop X.Y.0bM`` (ex. 1.6.0b3)
@@ -98,8 +98,8 @@ for major releases
* ``git commit -am 'Bump to X.Y.0 final'``
* ``make clean``
* ``python setup.py release bdist_wheel sdist``
-* ``twine check dist/Sphinx-X.Y.Z*``
-* ``twine upload dist/Sphinx-X.Y.Z* --sign --identity [your GPG key]``
+* ``twine check dist/Sphinx-*``
+* ``twine upload dist/Sphinx-* --sign --identity [your GPG key]``
* open https://pypi.org/project/Sphinx/ and check there are no obvious errors
* ``git tag vX.Y.0``
* ``python utils/bump_version.py --in-develop X.Y.1b0`` (ex. 1.6.1b0)