summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorroberto@sirius <roberto@sirius>2010-03-08 13:25:02 +0100
committerroberto@sirius <roberto@sirius>2010-03-08 13:25:02 +0100
commit175ef65d9fb984dd76ada431b9e08b3b1d066f26 (patch)
tree62a088ad438bfc1fd0d130f11b1d5c886c7e3b5e /Makefile
parent8a572a642ec4ae07a0551dd1610498262fc6c2d0 (diff)
downloaduwsgi-175ef65d9fb984dd76ada431b9e08b3b1d066f26.tar.gz
new build system
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/Makefile b/Makefile
index 8a1b693e..d51bf425 100644
--- a/Makefile
+++ b/Makefile
@@ -1,14 +1,2 @@
-CC=gcc
-
-PYTHON_CFLAGS=`python-config --cflags`
-PYTHON_LIBS=`python-config --libs`
-
-UWSGI_CFLAGS=`python uwsgiconfig.py --cflags`
-UWSGI_LDFLAGS=`python uwsgiconfig.py --ldflags`
-
-CFLAGS=$(PYTHON_CFLAGS) $(UWSGI_CFLAGS)
-LD_FLAGS=$(PYTHON_LIBS) $(UWSGI_LDFLAGS) -export-dynamic
-
-PROGRAM=uwsgi
-
-include base.mk
+all:
+ python uwsgiconfig.py --build