summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAmir Masoud Abdol <amirmasoudabdol@icloud.com>2022-10-25 17:03:01 +0200
committerAmir Masoud Abdol <amirmasoudabdol@icloud.com>2022-10-26 08:20:01 +0200
commitd3460c1f235cccc183148596d906350f0c2e06da (patch)
tree0a7b29fca0378bcc894563a185970f2e394f43eb /CMakeLists.txt
parenta427b5203b023f74d345aa5628c8cc1a8902a1c4 (diff)
downloadqt5-d3460c1f235cccc183148596d906350f0c2e06da.tar.gz
Enable CMAKE_MESSAGE_CONTEXT_SHOW
This enables the CMake Message Context across the qt5 repo. Some of the messages were changed from NOTICE to STATUS so that the output looks more coherent and aligned. Change-Id: I4c9104479dd2af31da29cf8cfd20fdc77252d404 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6b3ad50..1fff3d0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,7 +57,7 @@ qt_internal_sort_module_dependencies("${QT_BUILD_SUBMODULES}" QT_BUILD_SUBMODULE
foreach(module IN LISTS QT_BUILD_SUBMODULES)
# Check for unmet dependencies
if(NOT DEFINED BUILD_${module} OR BUILD_${module})
- message(NOTICE "Checking dependencies of submodule '${module}'")
+ message(STATUS "Checking dependencies of submodule '${module}'")
get_property(required_deps GLOBAL PROPERTY QT_REQUIRED_DEPS_FOR_${module})
get_property(dependencies GLOBAL PROPERTY QT_DEPS_FOR_${module})
foreach(dep IN LISTS dependencies)
@@ -84,7 +84,7 @@ foreach(module IN LISTS QT_BUILD_SUBMODULES)
"but ${error_reason}.\n"
"Note: Use '-skip ${module}' to exclude it from the build.")
else()
- message(NOTICE "Skipping optional dependency '${dep}' of '${module}', "
+ message(STATUS "Skipping optional dependency '${dep}' of '${module}', "
"because ${error_reason}.")
endif()
endif()
@@ -92,8 +92,12 @@ foreach(module IN LISTS QT_BUILD_SUBMODULES)
endif()
endforeach()
+if(NOT DEFINED CMAKE_MESSAGE_CONTEXT_SHOW)
+ set(CMAKE_MESSAGE_CONTEXT_SHOW TRUE)
+endif()
+
foreach(module IN LISTS QT_BUILD_SUBMODULES)
- message(NOTICE "Configuring submodule '${module}'")
+ message(STATUS "Configuring submodule '${module}'")
ecm_optional_add_subdirectory("${module}")
if(module STREQUAL "qtbase")