summaryrefslogtreecommitdiff
path: root/examples/demos/maroon/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2023-05-02 12:25:58 +0200
committerKai Köhne <kai.koehne@qt.io>2023-05-02 12:03:42 +0000
commit835f15cfbb628938fcd7bfa4e334dec6199e54c6 (patch)
tree4fe262bce1e25eb99a578097d844440a1454cbc5 /examples/demos/maroon/CMakeLists.txt
parent3705d584d766098dc75fdcc87eb03658ae77be44 (diff)
downloadqtdoc-835f15cfbb628938fcd7bfa4e334dec6199e54c6.tar.gz
Use versioned CMake targets for Qt modules
Use e.g. Qt6::Core instead of Qt::Core. This is better matching the find_package(Qt6 ...) call, and also avoids issues that the versionless targets have. Pick-to: 6.5 Task-number: QTBUG-113277 Change-Id: I9bc7963d8524ef2ab061e32aef428711646247a7 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'examples/demos/maroon/CMakeLists.txt')
-rw-r--r--examples/demos/maroon/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/examples/demos/maroon/CMakeLists.txt b/examples/demos/maroon/CMakeLists.txt
index 0b05d880..2655517d 100644
--- a/examples/demos/maroon/CMakeLists.txt
+++ b/examples/demos/maroon/CMakeLists.txt
@@ -24,10 +24,10 @@ set_target_properties(maroon PROPERTIES
)
target_link_libraries(maroon PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Qml
+ Qt6::Quick
)
# Resources:
@@ -108,9 +108,9 @@ qt6_add_resources(maroon "maroon"
${maroon_resource_files}
)
-if(TARGET Qt::Multimedia)
+if(TARGET Qt6::Multimedia)
target_link_libraries(maroon PUBLIC
- Qt::Multimedia
+ Qt6::Multimedia
)
endif()