summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2022-01-19 09:24:44 +0100
committerDominik Holland <dominik.holland@googlemail.com>2022-01-27 13:50:04 +0100
commit71f21afe3afce5a86f9908b8854170c8c19e05c7 (patch)
tree5a1d662ead1da6ca3c839709e90cb7d16e29b736 /setup.py
parent8b267658200e087722eb9d70c31aec0d4be04a86 (diff)
downloadqtivi-qface-71f21afe3afce5a86f9908b8854170c8c19e05c7.tar.gz
Replace usage of 'typing.io' by 'typing'
With python 3.5 typing.io was integrated into the core libraries and no additional package is needed in order to use it. This also sets python 3.5 as the minimum version. Fixes: #104
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 90c33b5..bb9fbbd 100644
--- a/setup.py
+++ b/setup.py
@@ -44,13 +44,13 @@ setup(
keywords='qt code generator framework',
packages=find_packages(),
include_package_data=True,
+ python_requires=">=3.5",
install_requires=[
'click>=6.7',
'antlr4-python3-runtime>=4.7.1',
'jinja2>=2.10.3',
'path.py>=11.0.1',
'pyyaml>=5.1',
- 'typing>=3.6.4',
'watchdog>=0.8.3',
'six>=1.11.0',
'coloredlogs>=10.0',