summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-06-28 19:21:24 +0200
committerMichal Klocek <michal.klocek@qt.io>2021-06-30 17:53:01 +0200
commitb7da2b5040bb26771103076b7f5fdcb06d639612 (patch)
tree999ede31a781d92fb6a1116961705100f14b7b4a /CMakeLists.txt
parent1efcf20bcc1d41edb56d4ef491dc9c26b7a98f15 (diff)
downloadqtwebengine-b7da2b5040bb26771103076b7f5fdcb06d639612.tar.gz
Rename libs project to qtwebengine
This fits better with topLevel builds where you can do: cmake --build . -- qtwebengine Pick-to: 6.2 Change-Id: Ic698d110570ed31c5515bac77d56a5639f4ac3dd Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e35fcf7b9..f45fa111d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -139,7 +139,8 @@ else()
endif()
endif()
-externalproject_add(libs
+# use qtwebengine as name since it is should visible for topLevel builds
+externalproject_add(qtwebengine
SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/src
BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/src
PREFIX libs
@@ -158,14 +159,14 @@ externalproject_add(libs
)
# required for topLevel build
-add_implicit_dependencies(libs Core Gui Widgets Network OpenGL
+add_implicit_dependencies(qtwebengine Core Gui Widgets Network OpenGL
OpenGLWidgets Quick QuickWidgets Qml PrintSupport WebChannel Positioning
)
# Ensure the libs project is reconfigured if the root project is reconfigured, so that the
# correct CMake and qmake support files are used when building examples, rather than
# using the incomplete support files created by the root project.
-qt_internal_add_external_project_dependency_to_root_project(libs)
+qt_internal_add_external_project_dependency_to_root_project(qtwebengine)
if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
externalproject_add(qtwebengine_examples
@@ -177,7 +178,7 @@ if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
CMAKE_ARGS -DCMAKE_TOOLCHAIN_FILE=${CMAKE_TOOLCHAIN_FILE}
"${featureList}"
)
- externalproject_add_stepdependencies(qtwebengine_examples install libs)
+ externalproject_add_stepdependencies(qtwebengine_examples install qtwebengine)
endif()
if(FORCE_TEST_RUN OR QT_BUILD_TESTS)
@@ -198,14 +199,14 @@ if(FORCE_TEST_RUN OR QT_BUILD_TESTS)
INSTALL_COMMAND ""
${testRunCommand}
)
- externalproject_add_stepdependencies(qtwebengine_tests install libs)
+ externalproject_add_stepdependencies(qtwebengine_tests install qtwebengine)
if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
externalproject_add_stepdependencies(qtwebengine_tests install qtwebengine_examples)
endif()
endif()
if(NOT Gn_FOUND)
- externalproject_add_stepdependencies(libs install gn)
+ externalproject_add_stepdependencies(qtwebengine install gn)
endif()
if(NOT Ninja_FOUND)