summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-06-04 17:42:09 +0200
committerMichal Klocek <michal.klocek@qt.io>2021-06-14 16:27:48 +0200
commitf04bc6833c01efc0fb37d6f6c31c6fa427087664 (patch)
tree51ba296e0d1edcb38af22204d3dc160404960627 /CMakeLists.txt
parent9451ceee24e832d32a86ae6a2f37eea781acaa2f (diff)
downloadqtwebengine-f04bc6833c01efc0fb37d6f6c31c6fa427087664.tar.gz
CMake: Ensure libs project is reconfigured when the root project is
To ensure that correct CMake and qmake support files are used when building examples. Pick-to: 6.2 Change-Id: Ic52ee7f7153877071ab3883fd436ad888f90680d Reviewed-by: Michal Klocek <michal.klocek@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31ebb8687..e5e3d3613 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,6 +148,11 @@ externalproject_add(libs
COMMAND ${CMAKE_COMMAND} -E remove_directory ../mkspecs
)
+# Ensure the libs project is reconfigured if the root project is reconfigured, so that the
+# correct CMake and qmake support files are used when building examples, rather than
+# using the incomplete support files created by the root project.
+qt_internal_add_external_project_dependency_to_root_project(libs)
+
if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
externalproject_add(qtwebengine_examples
SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/examples