summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2016-11-07 14:28:54 -0500
committerSteve Dickson <steved@redhat.com>2016-11-07 14:33:43 -0500
commit0cc39c519278b15ede3a5268415b70a2378a52c0 (patch)
tree861e93d91ad9ef593b2fc62ea3249c4af018d567 /Makefile.am
parent196e8f3abaa6e8899ba2655c6c2d8751e33a9795 (diff)
downloadrpcbind-0cc39c519278b15ede3a5268415b70a2378a52c0.tar.gz
Provide systemd unit files for rpcbindrpcbind-0_2_4-rc2
To encourage uniformity across distributions, provide systemd unit files. If extra arguments are wanted for rpcbind, a drop-in should be used to set the Environment= or read and EnvironmentFile= Even though libtirpc and the kernel contact rpcbind via /var/run/rcpbind.sock, tell systemd to place the socket in /run/rpcbind.sock as systems using systemd always use /run, and often symlink /var/run to /run. rpcbind.service pulls in rpcbind.socket so that the listening sockets chosen there will always be used. Signed-off-by: NeilBrown <neilb@suse.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ec8cd6..43c2710 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,6 +50,10 @@ if SYSTEMD
AM_CPPFLAGS += $(SYSTEMD_CFLAGS) -DSYSTEMD
rpcbind_LDADD += $(SYSTEMD_LIBS)
+
+systemdsystemunit_DATA = \
+ systemd/rpcbind.service \
+ systemd/rpcbind.socket
endif
rpcinfo_SOURCES = src/rpcinfo.c