summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-18 17:02:46 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-18 17:02:46 -0700
commita93eb4cf381e0424e242f456991f6efbb9b876cf (patch)
treec0d50d7feb139ed661f4b8ca1c754ef984d90b6f /configure.ac
parent7fd24bef0fb5d3f7e07af433cfbdea0f00becdbc (diff)
downloadrsync-a93eb4cf381e0424e242f456991f6efbb9b876cf.tar.gz
Handle a missing c++ too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 15 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 3330eb90..85b97914 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,9 +203,9 @@ AC_ARG_ENABLE(simd,
if test x"$enable_simd" != x"no"; then
# For x86-64 SIMD, g++ >=5 or clang++ >=7 is required
if test x"$build_cpu" = x"x86_64"; then
+ CXX_OK=
if test x"$CXX" != x""; then
- CXX_OK=
- CXX_VERSION=`$CXX --version | head -n 1`
+ CXX_VERSION=`$CXX --version 2>/dev/null | head -n 1`
case "$CXX_VERSION" in
g++*)
CXX_VERSION=`$CXX -dumpversion | sed 's/\..*//g'`
@@ -220,16 +220,21 @@ if test x"$enable_simd" != x"no"; then
CXX_OK=yes
fi
;;
+ *)
+ CXX_VERSION='Unknown'
+ ;;
esac
-
- if test x"$CXX_OK" = x"yes"; then
- # AC_MSG_RESULT() is called below.
- SIMD="$SIMD x86_64"
- else
- AC_MSG_RESULT(error)
- AC_MSG_ERROR([Failed to find g++ >=5 or clang++ >=7 for SIMD optimizations.
+ else
+ CXX='No c++'
+ CXX_VERSION='Unknown'
+ fi
+ if test x"$CXX_OK" = x"yes"; then
+ # AC_MSG_RESULT() is called below.
+ SIMD="$SIMD x86_64"
+ else
+ AC_MSG_RESULT(error)
+ AC_MSG_ERROR([Failed to find g++ >=5 or clang++ >=7 for SIMD optimizations.
Specify --disable-simd to continue without it. ($CXX, $CXX_VERSION)])
- fi
fi
elif test x"$enable_simd" = x"yes"; then
AC_MSG_RESULT(unavailable)