summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-18 14:27:00 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-18 14:27:00 -0700
commitc6f89cbf9c2d163cb07e640e6b13002e5c98cb61 (patch)
tree040041f6e71d2a1f569c9f5fdc545df16808c34f /configure.ac
parent2921779c1f9f85e20bf75f7c3f5f8b6c48549701 (diff)
downloadrsync-c6f89cbf9c2d163cb07e640e6b13002e5c98cb61.tar.gz
Complain if we can't enable simd on non-x86_64.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a590af44..a65b289d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,6 +230,10 @@ if test x"$enable_simd" = x"yes"; then
Omit --enable-simd to continue without it. ($CXX, $CXX_VERSION)])
fi
fi
+ else
+ AC_MSG_RESULT(unavailable)
+ AC_MSG_ERROR(The SIMD optimizations are currently x86_64 only.
+Omit --enable-simd to continue.)
fi
fi