summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorbors <bors@rust-lang.org>2020-01-31 00:03:55 +0000
committerbors <bors@rust-lang.org>2020-01-31 00:03:55 +0000
commit138c50f0af57e2631aa09092b826e2c3efd224d2 (patch)
treec9ef3ad521415df72625bb6ec2edbd349abb8955 /Cargo.toml
parent34700c15c7a49d400951da385b2eacab6fb6fe86 (diff)
parent0d52c562db18e85cf53078c9ddb40abe469a4aab (diff)
downloadrust-138c50f0af57e2631aa09092b826e2c3efd224d2.tar.gz
Auto merge of #67878 - Others:opt-3, r=Mark-Simulacrum
Change opt-level from 2 back to 3 In Cargo.toml, the opt-level for `release` and `bench` was overridden to be 2. This was to work around a problem with LLVM 7. However, rust no longer uses LLVM 7, so this is hopefully no longer needed? I tried a little bit to replicate the original problem, and could not. I think running this through CI is the best way to smoke test this :) Even if things break dramatically, the comment should be updated to reflect that things are still broken with LLVM 9. I'm just getting started playing with the compiler, so apologies if I've missed an obvious problem here. fixes #52378 (possibly relevant is the [current update to LLVM 10](https://github.com/rust-lang/rust/pull/67759))
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 0 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9d5c27b96df..2f5a708e8dc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,13 +31,6 @@ exclude = [
"obj",
]
-# Curiously, LLVM 7.0 will segfault if compiled with opt-level=3
-# See issue https://github.com/rust-lang/rust/issues/52378
-[profile.release]
-opt-level = 2
-[profile.bench]
-opt-level = 2
-
# These options are controlled from our rustc wrapper script, so turn them off
# here and have them controlled elsewhere.
[profile.dev]