summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2018-08-13 15:18:26 +0800
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2018-09-10 15:16:53 +0200
commitfbcc448bac638a7ff26fa8657c1056399a337041 (patch)
tree8588b43dd0da6aed10ec1ab989efee5379f2fead /Makefile.am
parent491728c3b5d44dd86de21da8fbbbb23d4aec6c7c (diff)
downloadsigc++-fbcc448bac638a7ff26fa8657c1056399a337041.tar.gz
Build: Use NMake Makefiles for MSVC Builds
Since the MSVC projects are not created upon 'make dist' but is manually updated, use a set of NMake Makefiles that consumes sigc++/filelist.am as needed, so that whenever the list of sources is updated, we do not have to worry that the generated release tarballs have broken Visual Studio build files. The next commit will remove the Visual Studio project files. This should make maintenance of the Visual Studio build files easier.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 501d554..7a8ef5c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,7 @@ dist_noinst_SCRIPTS = autogen.sh
include $(srcdir)/MSVC_NMake/filelist.am
-dist_noinst_DATA = $(addprefix MSVC_NMake/,$(msvc_net2017_data)) CMakeLists.txt sigc++config.h.cmake cmake_uninstall.cmake.in
+dist_noinst_DATA = $(addprefix MSVC_NMake/,$(msvc_nmake_data)) CMakeLists.txt sigc++config.h.cmake cmake_uninstall.cmake.in
DISTCLEANFILES = MSVC_NMake/sigc++config.h