summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJackLivio <jack@livio.io>2016-09-23 10:29:08 -0400
committerGitHub <noreply@github.com>2016-09-23 10:29:08 -0400
commitcafed909b10654e34d0908019f05a92166846ec2 (patch)
tree63b944df2f0fc1e9d4a29065ee004500e35bc2f4 /CMakeLists.txt
parent00ba7ed25e75e47d28013f5154949dbd7966d1e7 (diff)
parentfdf308beee4f25b4b883194dd5c9c2ad0f46b904 (diff)
downloadsdl_core-cafed909b10654e34d0908019f05a92166846ec2.tar.gz
Merge pull request #722 from smartdevicelink/hotfix/cmake_check_for_udev_openssl
Check for OpenSSL and UDev while running cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4358b5b7e..9b2b200d20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -208,6 +208,7 @@ endif()
if (BUILD_USB_SUPPORT)
add_definitions(-DUSB_SUPPORT)
+ find_package(UDev REQUIRED)
message(STATUS "USB support is enabled")
endif()
@@ -618,6 +619,7 @@ add_custom_target(install-3rd_party
WORKING_DIRECTORY ${3RD_PARTY_BINARY_DIRECTORY}
)
+find_package(OpenSSL REQUIRED)
if(ENABLE_LOG)
include_directories ( ${LOG4CXX_INCLUDE_DIRECTORY} )
endif()