summaryrefslogtreecommitdiff
path: root/src/components/hmi_message_handler/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/hmi_message_handler/test/CMakeLists.txt')
-rw-r--r--src/components/hmi_message_handler/test/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/components/hmi_message_handler/test/CMakeLists.txt b/src/components/hmi_message_handler/test/CMakeLists.txt
new file mode 100644
index 0000000000..a8597b51bd
--- /dev/null
+++ b/src/components/hmi_message_handler/test/CMakeLists.txt
@@ -0,0 +1,57 @@
+# Copyright (c) 2014, Ford Motor Company
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# Redistributions of source code must retain the above copyright notice, this
+# list of conditions and the following disclaimer.
+#
+# Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following
+# disclaimer in the documentation and/or other materials provided with the
+# distribution.
+#
+# Neither the name of the Ford Motor Company nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+if(BUILD_TESTS)
+
+include_directories (
+ ${GMOCK_INCLUDE_DIRECTORY}
+ ${COMPONENTS_DIR}/hmi_message_handler/include
+)
+
+set(LIBRARIES
+ gmock
+ ApplicationManager
+ HMIMessageHandler
+)
+
+set(SOURCES
+ ${COMPONENTS_DIR}/hmi_message_handler/test/main.cc
+ ${COMPONENTS_DIR}/hmi_message_handler/test/mqueue_adapter_test.cc
+)
+
+if(${QT_HMI})
+ list (APPEND SOURCES
+ ${COMPONENTS_DIR}/hmi_message_handler/test/mock_subscriber.cc
+ ${COMPONENTS_DIR}/hmi_message_handler/test/dbus_message_adapter_test.cc
+ )
+endif()
+create_test("hmi_message_handler_test" "${SOURCES}" "${LIBRARIES}")
+
+endif() \ No newline at end of file