summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-03-23 11:12:22 +0000
committersnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-03-23 11:12:22 +0000
commit7d39bfaac9797f917d0d3b3717b17f4b6e609cc9 (patch)
treed32908c70787547346055fd8cfa0e6501e608023 /configure.ac
parent7dad5700705df3ff792f38bb8ee7c6381d50c8b8 (diff)
downloadsnappy-7d39bfaac9797f917d0d3b3717b17f4b6e609cc9.tar.gz
Fix public issue #4: Properly quote all macro arguments in configure.ac.
R=csilvers DELTA=16 (0 added, 0 deleted, 16 changed) Revision created by MOE tool push_codebase. MOE_MIGRATION=989 git-svn-id: http://snappy.googlecode.com/svn/trunk@7 03e5f5b5-db94-4691-08a0-1a8bf15f6143
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 16 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 72301b5..205be34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
-m4_define(snappy_major, [1])
-m4_define(snappy_minor, [0])
-m4_define(snappy_patchlevel, [0])
+m4_define([snappy_major], [1])
+m4_define([snappy_minor], [0])
+m4_define([snappy_patchlevel], [0])
# Libtool shared library interface versions (current:revision:age)
# Update this value for every release! (A:B:C will map to foo.so.(A-C).C.B)
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-m4_define(snappy_version, [1:0:0])
+m4_define([snappy_version], [1:0:0])
AC_INIT([snappy], [snappy_major.snappy_minor.snappy_patchlevel])
AC_CONFIG_MACRO_DIR([m4])
@@ -14,11 +14,11 @@ LT_INIT
AC_PROG_CXX
AC_LANG([C++])
AC_C_BIGENDIAN
-AC_CHECK_HEADERS(stdint.h stddef.h)
+AC_CHECK_HEADERS([stdint.h stddef.h])
# Don't use AC_FUNC_MMAP, as it checks for mappings of already-mapped memory,
# which we don't need (and does not exist on Windows).
-AC_CHECK_FUNC(mmap)
+AC_CHECK_FUNC([mmap])
GTEST_LIB_CHECK([], [true], [true # Ignore; we can live without it.])
PKG_CHECK_MODULES([gflags], [libgflags],
@@ -40,7 +40,7 @@ AC_TRY_COMPILE(, [
AC_MSG_RESULT([no])
])
if test x$snappy_have_builtin_expect = xyes ; then
- AC_DEFINE(HAVE_BUILTIN_EXPECT, 1, [Define to 1 if the compiler supports __builtin_expect.])
+ AC_DEFINE([HAVE_BUILTIN_EXPECT], [1], [Define to 1 if the compiler supports __builtin_expect.])
fi
# See if we have working count-trailing-zeros intrinsics.
@@ -57,7 +57,7 @@ AC_TRY_COMPILE(, [
AC_MSG_RESULT([no])
])
if test x$snappy_have_builtin_ctz = xyes ; then
- AC_DEFINE(HAVE_BUILTIN_CTZ, 1, [Define to 1 if the compiler supports __builtin_ctz and friends.])
+ AC_DEFINE([HAVE_BUILTIN_CTZ], [1], [Define to 1 if the compiler supports __builtin_ctz and friends.])
fi
# Other compression libraries; the unit test can use these for comparison
@@ -70,14 +70,14 @@ AC_CHECK_LIB([quicklz], [qlz_compress],, [true])
# These are used by snappy-stubs-public.h.in.
if test "$ac_cv_header_stdint_h" = "yes"; then
- AC_SUBST(ac_cv_have_stdint_h, 1)
+ AC_SUBST([ac_cv_have_stdint_h], [1])
else
- AC_SUBST(ac_cv_have_stdint_h, 0)
+ AC_SUBST([ac_cv_have_stdint_h], [0])
fi
if test "$ac_cv_header_stddef_h" = "yes"; then
- AC_SUBST(ac_cv_have_stddef_h, 1)
+ AC_SUBST([ac_cv_have_stddef_h], [1])
else
- AC_SUBST(ac_cv_have_stddef_h, 0)
+ AC_SUBST([ac_cv_have_stddef_h], [0])
fi
# Export the version to snappy-stubs-public.h.
@@ -85,14 +85,14 @@ SNAPPY_MAJOR="snappy_major"
SNAPPY_MINOR="snappy_minor"
SNAPPY_PATCHLEVEL="snappy_patchlevel"
-AC_SUBST(SNAPPY_MAJOR)
-AC_SUBST(SNAPPY_MINOR)
-AC_SUBST(SNAPPY_PATCHLEVEL)
+AC_SUBST([SNAPPY_MAJOR])
+AC_SUBST([SNAPPY_MINOR])
+AC_SUBST([SNAPPY_PATCHLEVEL])
# Set the libtool version for the library.
# (Note: snappy_version is an m4 macro, defined above.)
EXTRA_LIBSNAPPY_LDFLAGS="$EXTRA_LIBSNAPPY_LDFLAGS -version-info snappy_version"
-AC_SUBST(EXTRA_LIBSNAPPY_LDFLAGS)
+AC_SUBST([EXTRA_LIBSNAPPY_LDFLAGS])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile snappy-stubs-public.h])