summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-05-05 09:35:54 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-05-09 08:11:10 +0200
commit608923582980357c3feb3619231286e48c084f7d (patch)
tree93f4efb9576325de33f0182165147a02af931d18 /meson.build
parentba9ca60a88e1cf368ab59ee9c720caf0ec13a0b6 (diff)
downloadsystemd-608923582980357c3feb3619231286e48c084f7d.tar.gz
meson: add check-includes test to the test suite
Let's just call it always. It is quite fast (meson says 0.12 s).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 13 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 1fd22c4f45..9c35a701dd 100644
--- a/meson.build
+++ b/meson.build
@@ -4738,17 +4738,26 @@ if git.found()
run_target(
'ctags',
command : [env, 'ctags', '--tag-relative=never', '-o', '@0@/tags'.format(project_source_root)] + all_files)
+
+ ############################################
+
+ if want_tests != 'false' and conf.get('BUILD_MODE_DEVELOPER') == 1
+ test('check-includes',
+ files('tools/check-includes.py'),
+ args: all_files,
+ env : ['PROJECT_SOURCE_ROOT=@0@'.format(project_source_root)])
+ endif
endif
-endif
-if git.found()
+ ####################################################
+
git_contrib_sh = find_program('tools/git-contrib.sh')
run_target(
'git-contrib',
command : [git_contrib_sh])
-endif
-if git.found()
+ ####################################################
+
git_head = run_command(
git, '--git-dir=@0@/.git'.format(project_source_root),
'rev-parse', 'HEAD',