summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2022-12-16 18:42:39 +0100
committerLennart Poettering <lennart@poettering.net>2022-12-19 11:43:19 +0100
commit85f875357b144b7a6c6eba3556db828a6f10a436 (patch)
tree2f1ec1b479b9430ffae7269e3744e056382a9200 /meson.build
parent34ea7e02320f6f91c354a5c329eeb29f998dd731 (diff)
downloadsystemd-85f875357b144b7a6c6eba3556db828a6f10a436.tar.gz
bootctl: split out random seed verb, too
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f0b7b8958e..d4d19dc0a8 100644
--- a/meson.build
+++ b/meson.build
@@ -2606,8 +2606,13 @@ if conf.get('HAVE_BLKID') == 1 and conf.get('HAVE_GNU_EFI') == 1
exe = executable(
'bootctl',
['src/boot/bootctl.c',
+ 'src/boot/bootctl.h',
+ 'src/boot/bootctl-random-seed.c',
+ 'src/boot/bootctl-random-seed.h',
'src/boot/bootctl-reboot-to-firmware.c',
- 'src/boot/bootctl-reboot-to-firmware.h'],
+ 'src/boot/bootctl-reboot-to-firmware.h',
+ 'src/boot/bootctl-util.c',
+ 'src/boot/bootctl-util.h'],
include_directories : includes,
link_with : [boot_link_with],
dependencies : [libblkid,