summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaan De Meyer <daan.j.demeyer@gmail.com>2022-09-09 10:27:57 +0200
committerDominique Martinet <asmadeus@codewreck.org>2022-10-06 07:31:20 +0900
commite2490f73849181d840bdbb6265b8df2bb0111062 (patch)
tree1ba902597b385cdeac37799369eb77c18858db89 /meson.build
parent4163c87731579030154436760d362499d37fceba (diff)
downloadsystemd-e2490f73849181d840bdbb6265b8df2bb0111062.tar.gz
Bump libbpf version to 0.7
We already depend on the skeleton APIs introduced in libbpf 0.7 so let's bump our minimum version to reflect that. We don't enforce bpf compilation on mkosi anymore since not all distros have sufficiently up-to-date libbpf available.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e76cc1dc6b..0b5fdd1737 100644
--- a/meson.build
+++ b/meson.build
@@ -1050,7 +1050,7 @@ want_bpf_framework = get_option('bpf-framework')
bpf_compiler = get_option('bpf-compiler')
bpf_framework_required = want_bpf_framework == 'true'
-libbpf_version_requirement = '>= 0.2.0'
+libbpf_version_requirement = '>= 0.7.0'
if bpf_compiler == 'gcc'
libbpf_version_requirement = '>= 1.0.0'
endif