summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Thompson <will.thompson@collabora.co.uk>2011-07-07 14:33:50 +0100
committerWill Thompson <will.thompson@collabora.co.uk>2011-07-07 15:39:12 +0100
commit10287449e56eb7acb54572948b4ce9aaa0a0cd52 (patch)
treeccb4f292001c7cb0a6f325c26fabbfa799f17630 /Makefile.am
parent2cb08f95c385adaf10b5a4a9cfe127cfbfdf1ddc (diff)
downloadtelepathy-salut-10287449e56eb7acb54572948b4ce9aaa0a0cd52.tar.gz
Add and use telepathy.am and make-release-mail.py
This will let me use maintainer-make-release, and adds checks for things like UNRELEASED.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index ba099d87..f960e59f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,13 +4,6 @@ SUBDIRS = tools extensions lib src data m4 tests docs plugins salut
DISTCHECK_CONFIGURE_FLAGS = --disable-debug --enable-gtk-doc
-dist-hook:
- chmod u+w ${distdir}/ChangeLog
- if test -d ${top_srcdir}/.git; then \
- git log --stat > ${distdir}/ChangeLog || \
- git log > ${distdir}/ChangeLog; \
- fi
-
valgrind:
cd tests && $(MAKE) valgrind
@@ -21,3 +14,12 @@ forever:
cd tests && $(MAKE) forever
include $(top_srcdir)/rules/lcov.mak
+
+# There doesn't seem to be a telepathy-salut-0.4.0 tag! :o
+CHANGELOG_RANGE = 22651d24..
+CHECK_FOR_UNRELEASED = \
+ $(srcdir)/NEWS \
+ $(wildcard $(srcdir)/salut/*.[ch]) \
+ $(wildcard $(srcdir)/src/*.[ch])
+
+include tools/telepathy.am