summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index ba099d87..f960e59f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,13 +4,6 @@ SUBDIRS = tools extensions lib src data m4 tests docs plugins salut
DISTCHECK_CONFIGURE_FLAGS = --disable-debug --enable-gtk-doc
-dist-hook:
- chmod u+w ${distdir}/ChangeLog
- if test -d ${top_srcdir}/.git; then \
- git log --stat > ${distdir}/ChangeLog || \
- git log > ${distdir}/ChangeLog; \
- fi
-
valgrind:
cd tests && $(MAKE) valgrind
@@ -21,3 +14,12 @@ forever:
cd tests && $(MAKE) forever
include $(top_srcdir)/rules/lcov.mak
+
+# There doesn't seem to be a telepathy-salut-0.4.0 tag! :o
+CHANGELOG_RANGE = 22651d24..
+CHECK_FOR_UNRELEASED = \
+ $(srcdir)/NEWS \
+ $(wildcard $(srcdir)/salut/*.[ch]) \
+ $(wildcard $(srcdir)/src/*.[ch])
+
+include tools/telepathy.am