summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-10 16:08:32 +0200
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-11 15:36:39 +0200
commitf975459090db7972390aec5461974a02a8738e00 (patch)
tree0ccf8260bd3faac19e7e4f09b1f412f62debb42c /configure.ac
parentb25cffc50890b723c84ad53169caabacfabefd16 (diff)
downloadtelepathy-salut-f975459090db7972390aec5461974a02a8738e00.tar.gz
configure: add summary
https://bugs.freedesktop.org/show_bug.cgi?id=69216
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c1f1da5..930ea94a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,7 @@ AS_IF([test x$with_backend = xavahi],
AC_SUBST(AVAHI_CFLAGS)
AC_SUBST(AVAHI_LIBS)
AC_SUBST(USE_BACKEND_AVAHI)
+ backend="Avahi"
])
dnl Check for Bonjour Client Library libdns_sd
@@ -252,12 +253,14 @@ AS_IF([test x$with_backend = xbonjour],
AC_SUBST(BONJOUR_CFLAGS)
AC_SUBST(BONJOUR_LIBS)
AC_SUBST(USE_BACKEND_BONJOUR)
+ backend="Bonjour"
])
AS_IF([test x$with_backend = xno],
[
AC_DEFINE(USE_BACKEND_DUMMY, [], [Use dummy backend])
AC_SUBST(USE_BACKEND_DUMMY)
+ backend="Dummy"
])
dnl Check for libsoup
@@ -382,3 +385,27 @@ AC_OUTPUT( Makefile \
salut/telepathy-salut-uninstalled.pc \
salut/telepathy-salut.pc
)
+
+if test false != "$TEST_PYTHON"; then
+ tests_enabled=yes
+else
+ tests_enabled=no
+fi
+
+echo "
+Configure summary:
+
+ Compiler....................: ${CC}
+ Compiler Flags..............: ${CFLAGS} ${ERROR_CFLAGS}
+ Prefix......................: ${prefix}
+ Backend.....................: ${backend}
+ Enable debug................: ${enable_debug}
+ Python tests................: ${tests_enabled}
+ Avahi tests.................: ${enable_avahi_tests}
+ Plugins.....................: ${enable_plugins}
+
+Features:
+
+ OLPC support................: ${enable_olpc}
+
+"