summaryrefslogtreecommitdiff
path: root/compiler/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2015-04-12 21:43:12 +0200
committerRoger Meier <roger@apache.org>2015-04-12 21:43:12 +0200
commit5af78c8776a668c6b46a1eba33823a068d16f1f3 (patch)
tree7966c7f364bd3e5f9ad1a5be5e7c0837471f4fb3 /compiler/cpp/CMakeLists.txt
parent81b3c440c64a372b6e47f9cb50804bd60f83e83f (diff)
downloadthrift-5af78c8776a668c6b46a1eba33823a068d16f1f3.tar.gz
Revert "THRIFT-3014 AppVeyor support - fix format"
This reverts commit 81b3c440c64a372b6e47f9cb50804bd60f83e83f. commit included modified CMakeLists.txt files, as part from local test
Diffstat (limited to 'compiler/cpp/CMakeLists.txt')
-rw-r--r--compiler/cpp/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/compiler/cpp/CMakeLists.txt b/compiler/cpp/CMakeLists.txt
index 26bf7cac4..ddbe9ea49 100644
--- a/compiler/cpp/CMakeLists.txt
+++ b/compiler/cpp/CMakeLists.txt
@@ -17,6 +17,9 @@
# under the License.
#
+
+cmake_minimum_required(VERSION 2.8)
+
# Windows has a different header
if(MSVC)
set(FLEX_FLAGS "--wincompat") # Don't use unistd.h on windows
@@ -49,7 +52,7 @@ set(libparse_SOURCES
add_library(libparse STATIC ${libparse_SOURCES})
# Create the thrift compiler
-set( thrift_SOURCES
+set( thrift_SOURCES
src/main.cc
src/md5.c
src/generate/t_generator.cc