summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJames E. King, III <jking@apache.org>2017-01-25 20:41:06 -0500
committerJames E. King, III <jking@apache.org>2017-01-25 20:41:06 -0500
commit71eba643ddc10bd2a9f614348567bfc1f63d8d06 (patch)
tree2d72bc7e150e4cf4e1345c3f6633b608ce1d4531 /debian
parentcf254894026988c7aa1e9742117c091f902cc838 (diff)
downloadthrift-71eba643ddc10bd2a9f614348567bfc1f63d8d06.tar.gz
THRIFT-4033 disable thrift compiler plug-in support by default, as the thrift-compiler packaging is not ready for it yet
This closes #1157
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index adecf0777..46a7f92f7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,7 +29,7 @@ configure-stamp:
# Add here commands to configure the package.
if [ -f bootstrap.sh ]; then $(CURDIR)/bootstrap.sh; fi
- $(CURDIR)/configure --prefix=/usr
+ $(CURDIR)/configure --prefix=/usr --enable-plugin=no
touch configure-stamp
@@ -42,12 +42,12 @@ build: build-arch build-indep
build-arch: build-arch-stamp
$(CURDIR)/compiler/cpp/thrift build-arch-stamp: configure-stamp
- # Compile C++ library
- $(MAKE) -C $(CURDIR)/lib/cpp
-
# Compile compiler
$(MAKE) -C $(CURDIR)/compiler/cpp
+ # Compile C++ library
+ $(MAKE) -C $(CURDIR)/lib/cpp
+
# Compile C (glib) library
$(MAKE) -C $(CURDIR)/lib/c_glib