summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Podgorny <radek@podgorny.cz>2014-05-28 13:30:53 +0200
committerRadek Podgorny <radek@podgorny.cz>2014-05-28 13:30:53 +0200
commit1d9e2624cd6504372cbac043fdb6bf82c09c4c48 (patch)
tree5134a19461a524639d5676ab4e8fec28151decdd /CMakeLists.txt
parent0c13bbf72030e75d8262ec13f096629bb538a142 (diff)
downloadunionfs-fuse-1d9e2624cd6504372cbac043fdb6bf82c09c4c48.tar.gz
add liulk's patch for mac os xHEADmaster
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3d2f87..b5b17c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,10 @@ SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
SET(CMAKE_C_FLAGS_RELEASE "-O2")
SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -DDEBUG")
+if (UNIX AND APPLE)
+ include_directories("/usr/local/include/osxfuse/fuse")
+endif()
+
add_definitions(-D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26)
option(WITH_XATTR "Enable support for extended attributes" OFF)