summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <gkiagia@tolabaki.gr>2016-07-03 21:33:09 +0300
committerGeorge Kiagiadakis <gkiagia@tolabaki.gr>2016-07-04 17:31:59 +0300
commit0a3f87a744031943239b8925973114147ff95aae (patch)
tree3faf0c473d682d040d232b1c53673295dd0cd168 /configure.ac
parentd54cde71584efcaf29dc76dff9125830929f5ad3 (diff)
downloadwocky-0a3f87a744031943239b8925973114147ff95aae.tar.gz
Bump required glib version to 2.44, as we now depend on GIO http proxy
Since g_type_init() is deprecated in more recent glib versions, also remove all calls of it to fix compilation. g_type_init() is not necessary to be called anymore, it is a no-op. https://bugs.freedesktop.org/show_bug.cgi?id=94031 Reviewed-by: Diane Trout <diane@ghic.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0e99203..2046fad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,10 +119,10 @@ AC_C_BIGENDIAN
dnl Check for Glib
PKG_CHECK_MODULES(GLIB,
- [glib-2.0 >= 2.32, gobject-2.0 >= 2.32, gthread-2.0 >= 2.32, gio-2.0 >= 2.32])
+ [glib-2.0 >= 2.44, gobject-2.0 >= 2.44, gthread-2.0 >= 2.44, gio-2.0 >= 2.44])
-AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_32], [Ignore post 2.32 deprecations])
-AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_32], [Prevent post 2.32 APIs])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_44], [Ignore post 2.44 deprecations])
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_44], [Prevent post 2.44 APIs])
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)