summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2015-05-19 12:36:34 -0400
committerColin Walters <walters@verbum.org>2015-05-19 12:36:34 -0400
commit290253b4e2f5f24a80efda5a3183b02602904399 (patch)
tree61a41b6c64a4ba0ca9ef75890f2266117d6bcacd /Makefile.am
parentea4adc2a8b771948c2ed56ff7f1ff6e5d77cca72 (diff)
downloadxdg-app-290253b4e2f5f24a80efda5a3183b02602904399.tar.gz
build: Fix srcdir != builddir from git
We could just `mkdir -p profile`, but it's saner to just drop it in the builddir.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b993a0..e71ec3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -148,9 +148,9 @@ completion_DATA = completion/xdg-app
EXTRA_DIST += $(completion_DATA)
profiledir = $(sysconfdir)/profile.d
-profile_DATA = profile/xdg-app.sh
+profile_DATA = xdg-app.sh
EXTRA_DIST += profile/xdg-app.sh.in
-profile/xdg-app.sh: profile/xdg-app.sh.in
+xdg-app.sh: profile/xdg-app.sh.in
$(AM_V_GEN) $(SED) -e "s|\@localstatedir\@|$(localstatedir)|" \
-e "s|\@sysconfdir\@|$(sysconfdir)|" $< > $@