summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-12-11 18:54:51 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-12-11 18:54:51 -0800
commita527e14d16de2955dcdd6d14141f51987af7af2c (patch)
treef5421d0d4eab26c8d0fff7f62efe8516f4dce5f3 /Makefile.am
parentfa9b494baacab74d354ee4d5e0f6a1342b2bc723 (diff)
downloadxorg-app-xauth-a527e14d16de2955dcdd6d14141f51987af7af2c.tar.gz
Add hooks for checking source code with lint/sparse/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e3b2f5..948c2aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,15 @@ appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
EXTRA_DIST = $(appman_PRE) ChangeLog
CLEANFILES = $(appman_DATA)
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(xauth_CFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(xauth_SOURCES) $(xauth_LDADD)
+endif LINT
+
+
SED = sed
# Strings to replace in man pages