summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 13:34:27 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 16:13:14 -0700
commit35eb34a9513467a88bf5e59f5cb44beb993753db (patch)
treea16516455567b8575fb997a9d8acad02a088cb8c /test/Makefile.am
parentd729c59e46a939f5179e711dec9a53ef1e9cd1b4 (diff)
downloadxorg-lib-libXmu-35eb34a9513467a88bf5e59f5cb44beb993753db.tar.gz
test: Add simple test cases for functions in src/reallocarray.c
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 807276a..f15fc0e 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -35,6 +35,7 @@ check_PROGRAMS = \
EditResStream \
Lower \
ReadBitmapData \
+ reallocarray \
StrToBS \
StrToGrav \
StrToJust \
@@ -63,6 +64,9 @@ Lower_LDADD = $(XMUU_TEST_LIBS)
ReadBitmapData_SOURCES = ReadBitmapData.c
ReadBitmapData_LDADD = $(XMU_TEST_LIBS)
+reallocarray_SOURCES = reallocarray.c
+reallocarray_LDADD = $(GLIB_LIBS)
+
StrToBS_SOURCES = StrToBS.c
StrToBS_LDADD = $(XMU_TEST_LIBS)