summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 09:06:08 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 16:13:14 -0700
commitd729c59e46a939f5179e711dec9a53ef1e9cd1b4 (patch)
tree213fe87c0e3d6eab1c38e162dd4c8ac7fbaf9d9c /test/Makefile.am
parent73764fa6f672a2aa540cae72155ba4ebfa1bcf4f (diff)
downloadxorg-lib-libXmu-d729c59e46a939f5179e711dec9a53ef1e9cd1b4.tar.gz
test: Add simple test cases for functions in src/StrToShap.c
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5fc2310..807276a 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -39,7 +39,8 @@ check_PROGRAMS = \
StrToGrav \
StrToJust \
StrToLong \
- StrToOrnt
+ StrToOrnt \
+ StrToShap
TESTS = $(check_PROGRAMS)
TESTS_ENVIRONMENT = $(MALLOC_DEBUG_ENV)
@@ -77,6 +78,9 @@ StrToLong_LDADD = $(XMU_TEST_LIBS)
StrToOrnt_SOURCES = StrToOrnt.c
StrToOrnt_LDADD = $(XMU_TEST_LIBS)
+StrToShap_SOURCES = StrToShap.c
+StrToShap_LDADD = $(XMU_TEST_LIBS)
+
endif HAVE_GLIB
endif ENABLE_UNIT_TESTS