summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-26 12:25:48 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 13:58:06 -0700
commitb6f70b5167557c8aa845feb53209d5b6ce58ce09 (patch)
tree3d908b68e074ad0dd8b7f9ae116053780c1b6ff1 /test/Makefile.am
parentb08c297a37c2b061de783b1954bb908796fe91b0 (diff)
downloadxorg-lib-libXmu-b6f70b5167557c8aa845feb53209d5b6ce58ce09.tar.gz
test: Add simple test cases for functions in src/CursorName.c
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5af50d1..75b95cb 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -30,7 +30,7 @@ AM_CFLAGS = $(CWARNFLAGS) $(XMU_CFLAGS) $(GLIB_CFLAGS)
XMU_TEST_LIBS = ${top_builddir}/src/libXmu.la $(XMU_LIBS) $(GLIB_LIBS)
XMUU_TEST_LIBS = ${top_builddir}/src/libXmuu.la $(XMUU_LIBS) $(GLIB_LIBS)
-check_PROGRAMS = EditResStream ReadBitmapData
+check_PROGRAMS = CursorName EditResStream ReadBitmapData
TESTS = $(check_PROGRAMS)
TESTS_ENVIRONMENT = $(MALLOC_DEBUG_ENV)
@@ -41,6 +41,9 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/tap-driver.sh
LOG_COMPILER = $(srcdir)/tap-test
+CursorName_SOURCES = CursorName.c
+CursorName_LDADD = $(XMUU_TEST_LIBS)
+
EditResStream_SOURCES = EditResStream.c
EditResStream_LDADD = $(XMU_TEST_LIBS)