summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-26 15:35:12 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 13:58:06 -0700
commitf7ad1689cbdf8b026b57844d584fdd7b5df3700b (patch)
treede7976059065d7cc85d8ad2faf9e9134c2d571a7 /test/Makefile.am
parentb6f70b5167557c8aa845feb53209d5b6ce58ce09 (diff)
downloadxorg-lib-libXmu-f7ad1689cbdf8b026b57844d584fdd7b5df3700b.tar.gz
test: Add simple test cases for functions in src/Lower.c
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 75b95cb..b4d9172 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -30,7 +30,7 @@ AM_CFLAGS = $(CWARNFLAGS) $(XMU_CFLAGS) $(GLIB_CFLAGS)
XMU_TEST_LIBS = ${top_builddir}/src/libXmu.la $(XMU_LIBS) $(GLIB_LIBS)
XMUU_TEST_LIBS = ${top_builddir}/src/libXmuu.la $(XMUU_LIBS) $(GLIB_LIBS)
-check_PROGRAMS = CursorName EditResStream ReadBitmapData
+check_PROGRAMS = CursorName EditResStream Lower ReadBitmapData
TESTS = $(check_PROGRAMS)
TESTS_ENVIRONMENT = $(MALLOC_DEBUG_ENV)
@@ -47,6 +47,9 @@ CursorName_LDADD = $(XMUU_TEST_LIBS)
EditResStream_SOURCES = EditResStream.c
EditResStream_LDADD = $(XMU_TEST_LIBS)
+Lower_SOURCES = Lower.c
+Lower_LDADD = $(XMUU_TEST_LIBS)
+
ReadBitmapData_SOURCES = ReadBitmapData.c
ReadBitmapData_LDADD = $(XMU_TEST_LIBS)