summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-07-10 11:32:48 +1000
committerRan Benita <ran@unusedvar.com>2020-08-30 21:49:41 +0300
commitd00cf64dbc586a1052e1f0d0e7f1a48bbff293ec (patch)
treea7d6fe367bad55b1ae0cc3c73722ddc6d8ebf664 /meson.build
parentd7b39f6ffbe9b46181c5597b0d0e7373eb2e9070 (diff)
downloadxorg-lib-libxkbcommon-d00cf64dbc586a1052e1f0d0e7f1a48bbff293ec.tar.gz
tools: add xkbcli-scaffold-new-layout as helper tool
This tool set ups the required directory structure and template files to add new keyboard layouts or options. For example, run like this: xkbcli-scaffold-new-layout --layout 'us(myvariant)' --option 'custom:foo' This will up the evdev rules file, the evdev.xml file, the symbols/us file and symbols/custom file in $XDG_CONFIG_HOME so that the user has everything in place and can start filling in the actual key mappings. This tool is currently uninstalled until we figure out whether it's useful. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c08b40b..465c98d 100644
--- a/meson.build
+++ b/meson.build
@@ -644,6 +644,14 @@ You can disable the Wayland xkbcli programs with -Denable-wayland=false.''')
install_man('tools/xkbcli-list.1')
endif
+ config_scaffold = configuration_data()
+ config_scaffold.set('XKBEXTRAPATH', XKBCONFIGEXTRAPATH)
+ config_scaffold.set('DEFAULT_XKB_RULES', get_option('default-rules'))
+ configure_file(input: 'tools/xkbcli-scaffold-new-layout.py',
+ output: 'xkbcli-scaffold-new-layout',
+ configuration: config_scaffold,
+ install: false)
+
test('tool-option-parsing',
find_program('test/tool-option-parsing.py'),
env: test_env,